aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-21 06:48:52 +0800
committerpav <pav@FreeBSD.org>2004-08-21 06:48:52 +0800
commitf08a7659a81028f222469ad7ca5c50108eb28fd5 (patch)
treec9d6bc4dd19a2fba213ab4a7fcffc0a741eb4a45 /www
parent29c5b5d9e6077657b05e23d00e91e08ce5d6bdcd (diff)
downloadfreebsd-ports-graphics-f08a7659a81028f222469ad7ca5c50108eb28fd5.tar.gz
freebsd-ports-graphics-f08a7659a81028f222469ad7ca5c50108eb28fd5.tar.zst
freebsd-ports-graphics-f08a7659a81028f222469ad7ca5c50108eb28fd5.zip
- Convert to OPTIONS
PR: ports/70727 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
Diffstat (limited to 'www')
-rw-r--r--www/rnews/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/www/rnews/Makefile b/www/rnews/Makefile
index e5ff0d27e42..7b31fcc909e 100644
--- a/www/rnews/Makefile
+++ b/www/rnews/Makefile
@@ -14,12 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A server-side rss aggregator written in php with mysql
-.if defined(WITH_PHP3)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
-.else
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
-.endif
-
USE_MYSQL= yes
NO_BUILD= yes
@@ -27,12 +21,14 @@ MYPORTDOCS= CHANGELOG INSTALL LICENSE README magpierss/AUTHORS \
magpierss/CHANGES magpierss/ChangeLog magpierss/INSTALL \
magpierss/NEWS magpierss/README magpierss/TROUBLESHOOTING
-pre-everything::
-.if !defined(WITH_PHP3)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Press CTRL-C and define WITH_PHP3 if you want"
- @${ECHO_MSG} "to use RNEWS with PHP3. PHP4 is used by default."
- @${ECHO_MSG} ""
+OPTIONS= PHP3 "use RNEWS with PHP3 (Default is PHP4)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PHP3)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
+.else
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
post-patch:
@@ -61,4 +57,4 @@ do-install:
@${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/www/rnews/magpierss/cache
@${SED} "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>