aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-04-21 19:43:12 +0800
committervanilla <vanilla@FreeBSD.org>2001-04-21 19:43:12 +0800
commitf0a2f2797f4d3272e245e7751bde364a15634c65 (patch)
tree172d9b14a805ee232c5d60d2e8797ff7a8f45e81 /www
parent4f94b9c8c7df606bab11c747db7be3620e297d1c (diff)
downloadfreebsd-ports-graphics-f0a2f2797f4d3272e245e7751bde364a15634c65.tar.gz
freebsd-ports-graphics-f0a2f2797f4d3272e245e7751bde364a15634c65.tar.zst
freebsd-ports-graphics-f0a2f2797f4d3272e245e7751bde364a15634c65.zip
Fix include directory for postgresql7.1's new layout.
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_pgsql/Makefile10
-rw-r--r--www/mod_auth_pgsql/files/patch-configure40
-rw-r--r--www/mod_php3/Makefile1
-rw-r--r--www/mod_php3/scripts/configure.php4
-rw-r--r--www/mod_php4/Makefile1
-rw-r--r--www/mod_php4/scripts/configure.php4
-rw-r--r--www/mod_php5/Makefile1
-rw-r--r--www/mod_php5/scripts/configure.php4
8 files changed, 54 insertions, 11 deletions
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index 1edca2dfcc4..73037103da4 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -6,15 +6,15 @@
PORTNAME= mod_auth_pgsql
PORTVERSION= 0.9.5a
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.eurolink.it/pub/linux/postgreSQL/mod_auth_pgsql/
MAINTAINER= mi@aldan.algebra.com
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT} \
- ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
-RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT} \
- ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT}
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
@@ -46,7 +46,7 @@ PLIST_SUB+= AUTH_PGSQL_DOCS="${AUTH_PGSQL_DOCS}"
PKGMESSAGE= ${WRKSRC}/.install_notes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pgsql=${PREFIX}/pgsql \
+CONFIGURE_ARGS= --with-pgsql=${PREFIX} \
--with-apxs=${APXS}
.if !defined(NOPORTDOCS)
diff --git a/www/mod_auth_pgsql/files/patch-configure b/www/mod_auth_pgsql/files/patch-configure
new file mode 100644
index 00000000000..f13c0017d00
--- /dev/null
+++ b/www/mod_auth_pgsql/files/patch-configure
@@ -0,0 +1,40 @@
+--- configure.orig Sat Apr 21 19:23:27 2001
++++ configure Sat Apr 21 19:24:38 2001
+@@ -1077,20 +1077,20 @@
+ withval="$with_pgsql"
+
+ if test "$withval" != "no" ; then
+- if test -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/include/pgsql/libpq-fe.h" ; then
+ PG_DIR=$withval
+- PG_INCLUDE="$withval/include"
++ PG_INCLUDE="$withval/include/pgsql"
+ PG_LIB="$withval/lib"
+ fi
+ if test "$PG_DIR" = "" ; then
+- if test -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/include/pgsql/libpq-fe.h" ; then
+ XML_DIR=$withval
+- XML_INCLUDE="$withval/include"
++ XML_INCLUDE="$withval/include/pgsql"
+ XML_LIB="$withval/lib"
+ fi
+ fi
+ if test "$PG_DIR" = "" ; then
+- if test -f "$withval/lib/libpq.a" -a -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/lib/libpq.a" -a -f "$withval/include/pgsql/libpq-fe.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include"
+ XML_LIB=$withval/lib
+@@ -1106,9 +1106,9 @@
+
+ if test "$PG_DIR" = ""; then
+ for i in /usr /usr/local /usr/local/postgres; do
+- if test -f "$i/include/libpq-fe.h"; then
++ if test -f "$i/include/pgsql/libpq-fe.h"; then
+ PG_DIR=$i
+- PG_INCLUDE="$i/include"
++ PG_INCLUDE="$i/include/pgsql"
+ PG_LIB="$i/lib"
+ elif test -f "$i/include/pgsql/libpq-fe.h"; then
+ PG_DIR=$i
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 51375fc6d36..179bcb76f2b 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php3
PORTVERSION= 3.0.18
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= ftp://ftp.php.net/pub/${PHP_DISTDIR}/ \
http://us.php.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index 5e7cad763a0..585b67f5d55 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -105,8 +105,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres | /usr/bin/grep -q "libssl"; then
LIBS="-lcrypto -lssl"
fi
;;
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 9c7ba331528..3ae8b2b8d5e 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 4bd4ef2a17d..585fb91eee0 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -113,8 +113,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 9c7ba331528..3ae8b2b8d5e 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 4bd4ef2a17d..585fb91eee0 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -113,8 +113,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi