aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2013-04-24 01:52:23 +0800
committerolgeni <olgeni@FreeBSD.org>2013-04-24 01:52:23 +0800
commitf349161c6f718fe7097f90b26e1913a034a7f106 (patch)
tree71e9db15ec50ca03e06747bdcd7931c68ecc0f9b /www
parentb4df5a19fbcc1400b7046169bed15779dd5c3613 (diff)
downloadfreebsd-ports-graphics-f349161c6f718fe7097f90b26e1913a034a7f106.tar.gz
freebsd-ports-graphics-f349161c6f718fe7097f90b26e1913a034a7f106.tar.zst
freebsd-ports-graphics-f349161c6f718fe7097f90b26e1913a034a7f106.zip
Add www/webmachine, an application layer that adds HTTP semantic
awareness on top of mochiweb.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webmachine/Makefile53
-rw-r--r--www/webmachine/distinfo2
-rw-r--r--www/webmachine/files/patch-rebar.config13
-rw-r--r--www/webmachine/pkg-descr6
-rw-r--r--www/webmachine/pkg-plist85
6 files changed, 160 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 20f4684b0be..d8c02465ddb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2032,6 +2032,7 @@
SUBDIR += webkit-sharp
SUBDIR += weblint
SUBDIR += weblint++
+ SUBDIR += webmachine
SUBDIR += webobjects
SUBDIR += webpy
SUBDIR += webreport
diff --git a/www/webmachine/Makefile b/www/webmachine/Makefile
new file mode 100644
index 00000000000..9c015f8f105
--- /dev/null
+++ b/www/webmachine/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= webmachine
+PORTVERSION= 1.10.1
+CATEGORIES= www devel
+MASTER_SITES= GH
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= HTTP semantic awareness on top mochiweb
+
+LICENSE= AL2
+
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
+ mochiweb-basho>=0:${PORTSDIR}/www/mochiweb-basho
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ mochiweb-basho>=0:${PORTSDIR}/www/mochiweb-basho
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+USE_GITHUB= yes
+GH_ACCOUNT= basho
+GH_PROJECT= webmachine
+GH_COMMIT= d600c0e
+GH_TAGNAME= ${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+do-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @for FILE in README.org; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${FILE} ${DOCSDIR}; \
+ done
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/ebin
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/include
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/priv
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/src
+ @${INSTALL_DATA} ${WRKSRC}/ebin/* ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/ebin
+ @${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/include
+ @${INSTALL_DATA} ${WRKSRC}/src/* ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/src
+ @cd ${WRKSRC}/priv && ${COPYTREE_SHARE} \* ${PREFIX}/lib/erlang/lib/webmachine-${PORTVERSION}/priv
+
+.include <bsd.port.post.mk>
diff --git a/www/webmachine/distinfo b/www/webmachine/distinfo
new file mode 100644
index 00000000000..6c8fc52f783
--- /dev/null
+++ b/www/webmachine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (webmachine-1.10.1.tar.gz) = cb0ce4822dfc4cb2d03c933d6c731a8dcc5d265054240a10b2a3a718bfd3cd3d
+SIZE (webmachine-1.10.1.tar.gz) = 1582684
diff --git a/www/webmachine/files/patch-rebar.config b/www/webmachine/files/patch-rebar.config
new file mode 100644
index 00000000000..968d5d221d1
--- /dev/null
+++ b/www/webmachine/files/patch-rebar.config
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- rebar.config.orig
++++ rebar.config
+@@ -4,6 +4,5 @@
+ {edoc_opts, [{preprocess, true}]}.
+
+ {deps, [
+- {mochiweb, "1.5.1*", {git, "git://github.com/basho/mochiweb",
+- {tag, "1.5.1p5"}}}
++ {mochiweb, "1.5.1*"}
+ ]}.
diff --git a/www/webmachine/pkg-descr b/www/webmachine/pkg-descr
new file mode 100644
index 00000000000..e9c2819609f
--- /dev/null
+++ b/www/webmachine/pkg-descr
@@ -0,0 +1,6 @@
+Webmachine is an application layer that adds HTTP semantic awareness
+on top of the excellent bit-pushing and HTTP syntax-management
+provided by mochiweb. It provides a simple and clean way to connect
+that to your application's behavior.
+
+WWW: https://github.com/basho/webmachine/
diff --git a/www/webmachine/pkg-plist b/www/webmachine/pkg-plist
new file mode 100644
index 00000000000..1787c178214
--- /dev/null
+++ b/www/webmachine/pkg-plist
@@ -0,0 +1,85 @@
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine.app
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_app.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_decision_core.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_deps.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_dispatcher.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error_handler.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_log.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_log_handler.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher_sup.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_mochiweb.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_multipart.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_perf_log_handler.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_request.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_resource.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_router.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_sup.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_util.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/wmtrace_resource.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin/wrq.beam
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include/webmachine.hrl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include/webmachine_logger.hrl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include/wm_reqdata.hrl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include/wm_reqstate.hrl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include/wm_resource.hrl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/Makefile
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/README
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/priv/dispatch.conf
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/rebar.config
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel.app.src
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_app.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_resource.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_sup.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/start.sh
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/wmskel.template
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/trace/http-headers-status-v3.png
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/trace/wmtrace.css
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/trace/wmtrace.js
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/www/index.html
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine.app.src
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_app.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_decision_core.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_deps.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_dispatcher.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error_handler.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_log.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_log_handler.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher_sup.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_mochiweb.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_multipart.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_perf_log_handler.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_request.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_resource.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_router.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_sup.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/webmachine_util.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/wmtrace_resource.erl
+%%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src/wrq.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/priv/dispatch.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_fs_resource.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_resource.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/start.sh
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/src
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/www
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/trace
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/src
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates/priv
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv/templates
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/priv
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/include
+@dirrm %%LIB32DIR%%/erlang/lib/webmachine-%%VERSION%%/ebin
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/priv
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%