aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-03-26 23:16:58 +0800
committermiwi <miwi@FreeBSD.org>2008-03-26 23:16:58 +0800
commitfb980d086f67f0a1a2defd3b28f5b2677d461bce (patch)
tree23b98c7604506d1cc7c364f515f2efc413f990fa /www
parentf3b7681847c226ee67ede4b37f2ae5f00b64373d (diff)
downloadfreebsd-ports-graphics-fb980d086f67f0a1a2defd3b28f5b2677d461bce.tar.gz
freebsd-ports-graphics-fb980d086f67f0a1a2defd3b28f5b2677d461bce.tar.zst
freebsd-ports-graphics-fb980d086f67f0a1a2defd3b28f5b2677d461bce.zip
WWW::Spinn3r is an iterative interface to the Spinn3r API. The Spinn3r
API is implemented over REST and XML and documented at http://spinn3r.com/documentation. Spinn3r service is available through a vendor key, which you can get from the good folks at Tailrank, http://spinn3r.com/contact. WWW: http://search.cpan.org/dist/WWW-Spinn3r/ PR: ports/121725 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Spinn3r/Makefile26
-rw-r--r--www/p5-WWW-Spinn3r/distinfo3
-rw-r--r--www/p5-WWW-Spinn3r/pkg-descr8
-rw-r--r--www/p5-WWW-Spinn3r/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 82926dbb525..abee034048d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -963,6 +963,7 @@
SUBDIR += p5-WWW-Shorten-0rz
SUBDIR += p5-WWW-Shorten-KUSO
SUBDIR += p5-WWW-SourceForge
+ SUBDIR += p5-WWW-Spinn3r
SUBDIR += p5-WWW-TV
SUBDIR += p5-WWW-TWSMS
SUBDIR += p5-WWW-VenusEnvy
diff --git a/www/p5-WWW-Spinn3r/Makefile b/www/p5-WWW-Spinn3r/Makefile
new file mode 100644
index 00000000000..11f1320bba1
--- /dev/null
+++ b/www/p5-WWW-Spinn3r/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WWW-Spinn3r
+# Date created: 2008-03-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Spinn3r
+PORTVERSION= 2.00100302
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= An interface to the Spinn3r API
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Spinn3r.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Spinn3r/distinfo b/www/p5-WWW-Spinn3r/distinfo
new file mode 100644
index 00000000000..3aac6ed6b96
--- /dev/null
+++ b/www/p5-WWW-Spinn3r/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Spinn3r-2.00100302.tar.gz) = 3fa9313efbc14585ef8a117dcced6258
+SHA256 (WWW-Spinn3r-2.00100302.tar.gz) = 3bcc69e20ad18a3b6cad07c8cde423abf122fa692ffc1a2f06d023e943a23ac9
+SIZE (WWW-Spinn3r-2.00100302.tar.gz) = 4172
diff --git a/www/p5-WWW-Spinn3r/pkg-descr b/www/p5-WWW-Spinn3r/pkg-descr
new file mode 100644
index 00000000000..34efe8c0538
--- /dev/null
+++ b/www/p5-WWW-Spinn3r/pkg-descr
@@ -0,0 +1,8 @@
+WWW::Spinn3r is an iterative interface to the Spinn3r API. The Spinn3r
+API is implemented over REST and XML and documented at
+http://spinn3r.com/documentation.
+
+Spinn3r service is available through a vendor key, which you can get
+from the good folks at Tailrank, http://spinn3r.com/contact.
+
+WWW: http://search.cpan.org/dist/WWW-Spinn3r/
diff --git a/www/p5-WWW-Spinn3r/pkg-plist b/www/p5-WWW-Spinn3r/pkg-plist
new file mode 100644
index 00000000000..9730dfe1140
--- /dev/null
+++ b/www/p5-WWW-Spinn3r/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Spinn3r/.packlist
+%%SITE_PERL%%/WWW/Spinn3r.pm
+@dirrmtry %%SITE_PERL%%/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Spinn3r
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW