aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks/wmfishtime/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-07 13:14:11 +0800
committerwill <will@FreeBSD.org>2001-04-07 13:14:11 +0800
commitec2874672043253b7bb25f09e2edfea7bcc178d7 (patch)
treecffc9ba6c08cf4c899599537a73119140f7b1e9b /x11-clocks/wmfishtime/Makefile
parent25018d8e45a31fa2f8875e7974b124a374c78a9f (diff)
downloadfreebsd-ports-graphics-ec2874672043253b7bb25f09e2edfea7bcc178d7.tar.gz
freebsd-ports-graphics-ec2874672043253b7bb25f09e2edfea7bcc178d7.tar.zst
freebsd-ports-graphics-ec2874672043253b7bb25f09e2edfea7bcc178d7.zip
Add wmfishtime 1.1, a time/date applet for WindowMaker with fishes
swimming around. PR: 26245 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'x11-clocks/wmfishtime/Makefile')
-rw-r--r--x11-clocks/wmfishtime/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
new file mode 100644
index 00000000000..a371c74a253
--- /dev/null
+++ b/x11-clocks/wmfishtime/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: wmfishtime
+# Date created: 31 March 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfishtime
+PORTVERSION= 1.1
+CATEGORIES= x11-clocks windowmaker
+MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+USE_GTK= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; s@-O3@${CFLAGS}@g; \
+ s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${PREFIX}/bin
+
+.include <bsd.port.mk>