aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks/wmtimer
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-10-01 04:59:04 +0800
committerlioux <lioux@FreeBSD.org>2001-10-01 04:59:04 +0800
commita919517976338243e496d53d66c408fc4a86dbad (patch)
tree6933b8216292b9ef474d521214c0d83554a889ba /x11-clocks/wmtimer
parentabee7e44cc2ef051ff4e7a26281620f0e2dee782 (diff)
downloadfreebsd-ports-graphics-a919517976338243e496d53d66c408fc4a86dbad.tar.gz
freebsd-ports-graphics-a919517976338243e496d53d66c408fc4a86dbad.tar.zst
freebsd-ports-graphics-a919517976338243e496d53d66c408fc4a86dbad.zip
- chase distfile checksum
- changes from Author Josh King <jking@dwave.net>: "Hello, I have added Multi-threaded support to allow the clock, timer and chronograph to keep going while the configure window is up. There have been a couple small changes to the dockapp to make the characters 'I' and ':' appear better and there has been a major rewrite/cleanup of the code." Submitted by: MAINTAINER
Diffstat (limited to 'x11-clocks/wmtimer')
-rw-r--r--x11-clocks/wmtimer/distinfo2
-rw-r--r--x11-clocks/wmtimer/files/patch-wmtimer::Makefile8
2 files changed, 5 insertions, 5 deletions
diff --git a/x11-clocks/wmtimer/distinfo b/x11-clocks/wmtimer/distinfo
index 7fab2a17abd..ceae858bf05 100644
--- a/x11-clocks/wmtimer/distinfo
+++ b/x11-clocks/wmtimer/distinfo
@@ -1 +1 @@
-MD5 (wmtimer-2.3.tar.gz) = 84346af2289b3c010d53529bdc260ee7
+MD5 (wmtimer-2.3.tar.gz) = c15efb30ceaa5b0510111830f373a696
diff --git a/x11-clocks/wmtimer/files/patch-wmtimer::Makefile b/x11-clocks/wmtimer/files/patch-wmtimer::Makefile
index 7ed46b55403..9327aa893af 100644
--- a/x11-clocks/wmtimer/files/patch-wmtimer::Makefile
+++ b/x11-clocks/wmtimer/files/patch-wmtimer::Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Sep 27 19:46:25 2001
-+++ Makefile Thu Sep 27 19:48:29 2001
+--- Makefile.orig Sat Sep 29 12:35:39 2001
++++ Makefile Sat Sep 29 12:37:20 2001
@@ -1,19 +1,19 @@
-LIBDIR = -L/usr/X11R6/lib -L/usr/lib
-LIBS = -lXpm -lXext -lX11 -lm `gtk-config --libs` -lpthread
@@ -7,7 +7,7 @@
+LIBS = -lXpm -lXext -lX11 -lm `${GTK_CONFIG} --libs` ${PTHREAD_LIBS}
-CFLAGS = -g -I/usr/X11R6/include `gtk-config --cflags`
-+CFLAGS += -I${X11BASE}/include `${GTK_CONFIG} --cflags` ${PTHREAD_CFLAGS} -Wall
++CFLAGS += -I${X11BASE}/include `${GTK_CONFIG} --cflags` ${PTHREAD_CFLAGS}
OBJS = wmtimer.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
@@ -20,7 +20,7 @@
all: wmtimer
wmtimer: $(OBJS)
-- cc -Wall -g -o wmtimer $^ $(LIBDIR) $(LIBS)
+- $(CC) -Wall -g -o wmtimer $^ $(LIBDIR) $(LIBS)
+ $(CC) -o wmtimer $^ $(LIBDIR) $(LIBS)
clean::