aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-input-mouse
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2008-03-13 22:06:52 +0800
committerflz <flz@FreeBSD.org>2008-03-13 22:06:52 +0800
commit91ce69ec25c5d05f97a69418c17679a8d638a577 (patch)
tree2c1d06b552cc1a5ba8cd0bdb9b31c34c35a74584 /x11-drivers/xf86-input-mouse
parent4db1e3b0b307be1bf196c66049f78a574b0e89db (diff)
downloadfreebsd-ports-graphics-91ce69ec25c5d05f97a69418c17679a8d638a577.tar.gz
freebsd-ports-graphics-91ce69ec25c5d05f97a69418c17679a8d638a577.tar.zst
freebsd-ports-graphics-91ce69ec25c5d05f97a69418c17679a8d638a577.zip
Add patch to fix possibly insecure mouse behavior when switching VT.
PR: ports/118694 Submitted by: J.R. Oldroyd <fbsd@opal.com> Obtained from: fd.o xorg/driver/xf86-input-mouse repository Commit id: 6a03e8bd9699a33dabcdd2bbcf51a001ddfd5534
Diffstat (limited to 'x11-drivers/xf86-input-mouse')
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile1
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-dont-flush-buttons-6a03e8bd38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index 6b2f8317620..d15f8e24266 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xf86-input-mouse
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-mouse/files/patch-dont-flush-buttons-6a03e8bd b/x11-drivers/xf86-input-mouse/files/patch-dont-flush-buttons-6a03e8bd
new file mode 100644
index 00000000000..d1a21ed5f30
--- /dev/null
+++ b/x11-drivers/xf86-input-mouse/files/patch-dont-flush-buttons-6a03e8bd
@@ -0,0 +1,38 @@
+From 6a03e8bd9699a33dabcdd2bbcf51a001ddfd5534 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter@cs.unisa.edu.au>
+Date: Fri, 16 Nov 2007 06:15:45 +0000
+Subject: Bug #13144: Don't flush buttons, release events can cause paste events.
+
+---
+diff --git src/mouse.c src/mouse.c
+index ff52d2b..bd98a80 100644
+--- src/mouse.c
++++ src/mouse.c
+@@ -1853,26 +1853,17 @@ MouseConvert(InputInfoPtr pInfo, int first, int num, int v0, int v1, int v2,
+
+ /**********************************************************************
+ *
+- * FlushButtons -- send button up events for sanity.
++ * FlushButtons -- reset button states.
+ *
+ **********************************************************************/
+
+ static void
+ FlushButtons(MouseDevPtr pMse)
+ {
+-
+- /* If no button down is pending xf86PostButtonEvent()
+- * will discard them. So we are on the safe side. */
+-
+ int i, blocked;
+
+ pMse->lastButtons = 0;
+ pMse->lastMappedButtons = 0;
+-
+- blocked = xf86BlockSIGIO ();
+- for (i = 1; i <= 5; i++)
+- xf86PostButtonEvent(pMse->device,0,i,0,0,0);
+- xf86UnblockSIGIO (blocked);
+ }
+
+ /**********************************************************************