aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-13 09:49:59 +0800
committermarcus <marcus@FreeBSD.org>2004-10-13 09:49:59 +0800
commit93b0b4507524d09e7b691408449216cf66379860 (patch)
treed9bc81d86f66067341f09ab75567d51aaa84a802 /x11-fm
parente25a0d19ee9d2ca158a93894bde6319cdab04dc3 (diff)
downloadfreebsd-ports-graphics-93b0b4507524d09e7b691408449216cf66379860.tar.gz
freebsd-ports-graphics-93b0b4507524d09e7b691408449216cf66379860.tar.zst
freebsd-ports-graphics-93b0b4507524d09e7b691408449216cf66379860.zip
Fix build, and chase new libexif.
Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus2/Makefile2
-rw-r--r--x11-fm/nautilus2/files/patch-components-image_properties-nautilus-image-properties-view.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index f5d7fa48239..52436b7e309 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
diff --git a/x11-fm/nautilus2/files/patch-components-image_properties-nautilus-image-properties-view.c b/x11-fm/nautilus2/files/patch-components-image_properties-nautilus-image-properties-view.c
new file mode 100644
index 00000000000..0f8441fabe6
--- /dev/null
+++ b/x11-fm/nautilus2/files/patch-components-image_properties-nautilus-image-properties-view.c
@@ -0,0 +1,12 @@
+--- components/image_properties/nautilus-image-properties-view.c.orig Thu Sep 30 15:41:33 2004
++++ components/image_properties/nautilus-image-properties-view.c Thu Sep 30 15:43:11 2004
+@@ -130,7 +130,8 @@
+ return;
+ }
+
+- attribute->value = g_strdup (exif_content_get_value (content, attribute->tag));
++ char value[1024];
++ attribute->value = g_strdup (exif_content_get_value (content, attribute->tag, value, sizeof(value)));
+ if (attribute->value != NULL) {
+ attribute->found = TRUE;
+ }