aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers/XFree86-4-VirtualFramebufferServer
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2002-07-19 04:30:22 +0800
committeranholt <anholt@FreeBSD.org>2002-07-19 04:30:22 +0800
commit7c6534363ec9839ed83bcc7eac6ca2fa5916be1c (patch)
tree6b0ed6cebd184a97bc0fd63a5d5ef11d13c2852e /x11-servers/XFree86-4-VirtualFramebufferServer
parent48c68e6fd6fafef9078c9ee9822279ffa9e003cb (diff)
downloadfreebsd-ports-graphics-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.tar.gz
freebsd-ports-graphics-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.tar.zst
freebsd-ports-graphics-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.zip
Make XFree86-4 miniports use imake-4's HasXdmAuth setting (default is YES).
Clean up Wraphelp.c inclusion in the ports that need it. Add USE_PERL5 to imake-4. Approved by: des
Diffstat (limited to 'x11-servers/XFree86-4-VirtualFramebufferServer')
-rw-r--r--x11-servers/XFree86-4-VirtualFramebufferServer/Makefile4
-rw-r--r--x11-servers/XFree86-4-VirtualFramebufferServer/scripts/configure41
2 files changed, 9 insertions, 36 deletions
diff --git a/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile b/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
index e5bf29b3205..d15f70c87e5 100644
--- a/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
+++ b/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
@@ -30,13 +30,13 @@ USE_IMAKE= YES
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
-SCRIPTS_ENV= HasXdmAuth=${HasXdmAuth}
ALL_TARGET= FreeBSDPortsBuild
INSTALL_TARGET= installXvfb installXserver.man
MAKE_ENV= MAN_INSTALL_TARGET=installXvfb.man
MAN1= Xserver.1 Xvfb.1
-HasXdmAuth?= YES
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.c ${WRKSRC}/lib/Xdmcp/
do-configure:
cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure
diff --git a/x11-servers/XFree86-4-VirtualFramebufferServer/scripts/configure b/x11-servers/XFree86-4-VirtualFramebufferServer/scripts/configure
index 917a76ead3f..95477973f61 100644
--- a/x11-servers/XFree86-4-VirtualFramebufferServer/scripts/configure
+++ b/x11-servers/XFree86-4-VirtualFramebufferServer/scripts/configure
@@ -1,14 +1,14 @@
#!/bin/sh
-# This scripts work as following:
-# (1) cp current xf86site.def (it may be created by imake-4 ports)
+# This script does the following:
+# (1) cp current xf86site.def (it is created by the imake-4 port)
# to ${WRKDIR}/xc/config/cf.
-# this means this ports use imake-4's config defaultly.
+# this means this port uses imake-4's config for defaults.
# (2) Generate temporal config for compiling.
# Some configs, such as `ForceNormalLib', `FreeBSDBuildXprog', are
-# used for compiling this ports localy. so these configs will be generated
-# this scripts. these configs will be stored to `host.def' file.
-# but this host.def will never install. use local only.
+# used locally for compiling this port, so these configs will be generated
+# by this script. These configs will be stored to the `host.def' file,
+# but this host.def will never be installed.
ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
@@ -49,36 +49,9 @@ configure () {
echo "#define XVirtualFramebufferServer YES" >> $LOCALDEF
echo "#define BuildServersOnly YES" >> $LOCALDEF
- # Check Wraphelp.c
- if [ $HasXdmAuth = DEFAULT ]; then
- HasXdmAuth=$(awk '/^#define.*HasXdmAuth/ {print $3}' $ORIGDEF|tail -1)
- fi
-
- cpwh=NO
- if [ $HasXdmAuth = YES ]; then
- WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
- if [ -f $WH ] ; then
- cpwh=SOURCE
- elif [ -f $DISTDIR/xc/Wraphelp.c ] ; then
- cpwh=$DISTDIR/xc/Wraphelp.c
- else
- echo "==> You must fetch USA-legal Wraphelp.c manually"
- echo "==> and put it to ${DISTDIR}/xc/."
- exit 1
- fi
- if [ X$cpwh != XNO -a X$cpwh != XSOURCE ]; then
- tr -d '\r' < $cpwh > $WH
- fi
- fi
-
# Copy ORIGDEF to DESTDEF
rm -f $DESTDEF
- grep -v '#define.*HasXdmAuth' $ORIGDEF >> $DESTDEF
- if [ $cpwh = NO ] ; then
- echo "#define HasXdmAuth NO" >> $DESTDEF
- else
- echo "#define HasXdmAuth YES" >> $DESTDEF
- fi
+ cp -f $ORIGDEF $DESTDEF
# copy generated config to host.def
cp -f $LOCALDEF $HOSTDEF