aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers/Xfstt/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-11-19 07:45:17 +0800
committerade <ade@FreeBSD.org>2000-11-19 07:45:17 +0800
commit4d381490dc23a0effc5946e5a7d20b10fb0b82c6 (patch)
tree1c58e97442f9876ef31627f58f612ec27cf8ae5a /x11-servers/Xfstt/Makefile
parente0d93f6a4bc1413b79ea8a35e9b02e9ea5fb51c0 (diff)
downloadfreebsd-ports-graphics-4d381490dc23a0effc5946e5a7d20b10fb0b82c6.tar.gz
freebsd-ports-graphics-4d381490dc23a0effc5946e5a7d20b10fb0b82c6.tar.zst
freebsd-ports-graphics-4d381490dc23a0effc5946e5a7d20b10fb0b82c6.zip
A whole bunch of updates from the new maintainer:
* install startup file * create TrueType directory * add new --notcp option (from ports/21957) and document it See PR for complete details PR: 22946 Submitted by: maintainer
Diffstat (limited to 'x11-servers/Xfstt/Makefile')
-rw-r--r--x11-servers/Xfstt/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-servers/Xfstt/Makefile b/x11-servers/Xfstt/Makefile
index 7fb16c6e5a2..fea95c40ae6 100644
--- a/x11-servers/Xfstt/Makefile
+++ b/x11-servers/Xfstt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfstt
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= x11-servers
MASTER_SITES= $(MASTER_SITE_SUNSITE)
MASTER_SITE_SUBDIR= X11/fonts
@@ -16,12 +17,22 @@ MAINTAINER= olgeni@uli.it
USE_X_PREFIX= yes
MAN1= xfstt.1
+.if defined(NOPORTDOCS)
+NODOCS= "@comment "
+.endif
+
+PLIST_SUB= NOPORTDOCS=${NODOCS}
+
do-install:
$(INSTALL_PROGRAM) $(WRKSRC)/xfstt $(PREFIX)/bin
$(INSTALL_MAN) $(WRKSRC)/xfstt.1x $(PREFIX)/man/man1/xfstt.1
post-install:
strip $(PREFIX)/bin/xfstt
+ ${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/xfstt.sh \
+ > ${PREFIX}/etc/rc.d/xfstt.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/xfstt.sh
+ $(MKDIR) $(PREFIX)/lib/X11/fonts/TrueType
.if !defined(NOPORTDOCS)
$(MKDIR) $(PREFIX)/share/doc/xfstt
$(INSTALL_DATA) $(WRKSRC)/FAQ $(PREFIX)/share/doc/xfstt
@@ -29,5 +40,8 @@ post-install:
$(INSTALL_DATA) $(WRKSRC)/INSTALL $(PREFIX)/share/doc/xfstt
$(INSTALL_DATA) $(WRKSRC)/THANKS.txt $(PREFIX)/share/doc/xfstt
.endif
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
.include <bsd.port.mk>