aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/e17-splash-blue/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-07 16:03:43 +0800
committerrafan <rafan@FreeBSD.org>2006-08-07 16:03:43 +0800
commitf75b1f5beed58da989fb4b591f0a34cd9663b07e (patch)
treed5c899f456cdd724526975a936d96103664e3ab1 /x11-themes/e17-splash-blue/Makefile
parent7a94ac54cd759cd87d162060ad510a14502b7273 (diff)
downloadfreebsd-ports-graphics-f75b1f5beed58da989fb4b591f0a34cd9663b07e.tar.gz
freebsd-ports-graphics-f75b1f5beed58da989fb4b591f0a34cd9663b07e.tar.zst
freebsd-ports-graphics-f75b1f5beed58da989fb4b591f0a34cd9663b07e.zip
Add e17-splash-blue 1.0, blue splash screen for e17 window manager.
PR: ports/101374 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'x11-themes/e17-splash-blue/Makefile')
-rw-r--r--x11-themes/e17-splash-blue/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/e17-splash-blue/Makefile b/x11-themes/e17-splash-blue/Makefile
new file mode 100644
index 00000000000..fe160e1e647
--- /dev/null
+++ b/x11-themes/e17-splash-blue/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-splash-blue
+# Date created: 4 Aug 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= blue
+PORTVERSION= 1.0
+CATEGORIES= x11-themes
+MASTER_SITES= http://www0.get-e.org/Themes/Startup/_files/
+PKGNAMEPREFIX= e17-splash-
+DISTNAME= init_blue
+EXTRACT_SUFX= .edj
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Blue splash screen for e17 window manager
+
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= share/enlightenment/data/init/init_blue.edj
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/enlightenment/data/init
+ ${INSTALL_DATA} ${WRKSRC}/${DISTFILES} \
+ ${PREFIX}/share/enlightenment/data/init
+
+.include <bsd.port.mk>