aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-04-15 07:24:04 +0800
committerlofi <lofi@FreeBSD.org>2005-04-15 07:24:04 +0800
commitaca5444ffeed29cf0d7d09b424f460def0b19068 (patch)
tree7cea993166d96f1209f4ddc4d2312991fd0a4623 /x11-themes
parent7d280260054f956e11b0134c05377b1f67be147f (diff)
downloadfreebsd-ports-graphics-aca5444ffeed29cf0d7d09b424f460def0b19068.tar.gz
freebsd-ports-graphics-aca5444ffeed29cf0d7d09b424f460def0b19068.tar.zst
freebsd-ports-graphics-aca5444ffeed29cf0d7d09b424f460def0b19068.zip
Add x11-themes/kdmtheme, a KDM theme manager.
PR: ports/79938 Submitted by: Eugene Lebedinec <illusia@inbox.lv>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Makefile1
-rw-r--r--x11-themes/kdmtheme/Makefile28
-rw-r--r--x11-themes/kdmtheme/distinfo2
-rw-r--r--x11-themes/kdmtheme/files/patch-src_kdmtheme.cpp13
-rw-r--r--x11-themes/kdmtheme/pkg-descr5
-rw-r--r--x11-themes/kdmtheme/pkg-message11
-rw-r--r--x11-themes/kdmtheme/pkg-plist11
7 files changed, 71 insertions, 0 deletions
diff --git a/x11-themes/Makefile b/x11-themes/Makefile
index 4b54dd0f2ec..6f9d3804ca4 100644
--- a/x11-themes/Makefile
+++ b/x11-themes/Makefile
@@ -100,6 +100,7 @@
SUBDIR += kde-icons-umicons
SUBDIR += kde-icons-wasp
SUBDIR += kdeartwork3
+ SUBDIR += kdmtheme
SUBDIR += lila-xfwm4
SUBDIR += linux-gtk-bluecurve-theme
SUBDIR += metacity-aluminumalloy-cryogenic-theme
diff --git a/x11-themes/kdmtheme/Makefile b/x11-themes/kdmtheme/Makefile
new file mode 100644
index 00000000000..217b0c55ec8
--- /dev/null
+++ b/x11-themes/kdmtheme/Makefile
@@ -0,0 +1,28 @@
+## New ports collection makefile for: KDM theme manager
+# Date created: 12 April 2005
+# Whom: illusia <illusia@inbox.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kdmtheme
+PORTVERSION= 0.9
+CATEGORIES= x11-themes
+MASTER_SITES= http://smileaf.org/files/
+DISTNAME= kdmtheme-${PORTVERSION}
+
+MAINTAINER= illusia@inbox.lv
+COMMENT= KDM Theme Manager
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_KDEBASE_VER=3
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-themes/kdmtheme/distinfo b/x11-themes/kdmtheme/distinfo
new file mode 100644
index 00000000000..77be994db02
--- /dev/null
+++ b/x11-themes/kdmtheme/distinfo
@@ -0,0 +1,2 @@
+MD5 (kdmtheme-0.9.tar.bz2) = 7fef92248f87cbedc86f9be934f997f3
+SIZE (kdmtheme-0.9.tar.bz2) = 607187
diff --git a/x11-themes/kdmtheme/files/patch-src_kdmtheme.cpp b/x11-themes/kdmtheme/files/patch-src_kdmtheme.cpp
new file mode 100644
index 00000000000..c9a2b772f55
--- /dev/null
+++ b/x11-themes/kdmtheme/files/patch-src_kdmtheme.cpp
@@ -0,0 +1,13 @@
+--- src/kdmtheme.cpp Wed Apr 6 07:50:26 2005
++++ src/kdmtheme.cpp Fri Apr 15 00:35:34 2005
+@@ -393,8 +393,8 @@
+
+ void kdmtheme::updateTheme( const QString &screenshot, const QString &copyright, const QString &description ) {
+ p_configWidget->Info->setText(
+- ((copyright.length() > 0)?i18n( "<b>Copyright:</b> " ) + copyright + "<br/>":"") +
+- ((description.length() > 0)?i18n( "<b>Description:</b> " ) + description:"") );
++ ((copyright.length() > 0)?i18n( "<b>Copyright:</b> " ) + copyright + ("<br/>"):QString("")) +
++ ((description.length() > 0)?i18n( "<b>Description:</b> " ) + description:QString("")) );
+ p_configWidget->Preview->setPixmap( screenshot );
+ }
+
diff --git a/x11-themes/kdmtheme/pkg-descr b/x11-themes/kdmtheme/pkg-descr
new file mode 100644
index 00000000000..daa316999a8
--- /dev/null
+++ b/x11-themes/kdmtheme/pkg-descr
@@ -0,0 +1,5 @@
+KDM Theme Manager is just what it says - a theme manager for KDM.
+This control module allows you to easily add, remove and select
+any KDM theme you want.
+
+WWW: http://kde-apps.org/content/show.php?content=22120
diff --git a/x11-themes/kdmtheme/pkg-message b/x11-themes/kdmtheme/pkg-message
new file mode 100644
index 00000000000..40bc8869b41
--- /dev/null
+++ b/x11-themes/kdmtheme/pkg-message
@@ -0,0 +1,11 @@
+
+
+=============================================
+How to use KDM theme manager:
+
+1) Open the KDE-menu and start Control Center
+2) Click on System Administration
+3) Select applet kdmtheme
+4) Have Fun :)
+
+=============================================
diff --git a/x11-themes/kdmtheme/pkg-plist b/x11-themes/kdmtheme/pkg-plist
new file mode 100644
index 00000000000..b7ca2a7a5ea
--- /dev/null
+++ b/x11-themes/kdmtheme/pkg-plist
@@ -0,0 +1,11 @@
+lib/kde3/kcm_kdmtheme.la
+lib/kde3/kcm_kdmtheme.so
+share/applications/kde/kdmtheme.desktop
+share/doc/HTML/en/kdmtheme/common
+share/doc/HTML/en/kdmtheme/index.cache.bz2
+share/doc/HTML/en/kdmtheme/index.docbook
+share/doc/HTML/en/kdmtheme/kdmtheme.png
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm share/doc/ja
+@dirrm share/doc/HTML/en/kdmtheme