aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/XawPlus/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-09-04 22:51:06 +0800
committerglewis <glewis@FreeBSD.org>2003-09-04 22:51:06 +0800
commit039a551cb0bf69b2bf8522750016d249a295c8cc (patch)
treea1ba92ebb317d32ef361a6e75c30d9771c7eb873 /x11-toolkits/XawPlus/Makefile
parent0d84a1209bf8765e8712588f8d9806a73147d1b2 (diff)
downloadfreebsd-ports-graphics-039a551cb0bf69b2bf8522750016d249a295c8cc.tar.gz
freebsd-ports-graphics-039a551cb0bf69b2bf8522750016d249a295c8cc.tar.zst
freebsd-ports-graphics-039a551cb0bf69b2bf8522750016d249a295c8cc.zip
. Add a port of XawPlus:
XawPlus is a clone of the original Xaw library, providing a more up to date look and some extensions to the original Athena widget set. This library is as compatible as possible to the original. It should be possible to compile the source code of an Xaw client without any changes (except the include path of the XawPlus header files) to get the new look of XawPlus to this client. XawPlus makes it possible to use XPM pixmaps, tooltips, a truncate mechanism for too long label strings and UTF8 coded UNICODE labels without changing the code of your application. XawPlus comes with a set of adapted applications using also the new features of XawPlus. WWW: http://people.freenet.de/kra/XawPlus PR: 47700 Submitted by: Normal User <freebsd@falx.port5.com>
Diffstat (limited to 'x11-toolkits/XawPlus/Makefile')
-rw-r--r--x11-toolkits/XawPlus/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-toolkits/XawPlus/Makefile b/x11-toolkits/XawPlus/Makefile
new file mode 100644
index 00000000000..0f2df6d5046
--- /dev/null
+++ b/x11-toolkits/XawPlus/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: XawPlus
+# Date created: 30 January 2003
+# Whom: DNPM <freebsd@falx.port5.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XawPlus
+PORTVERSION= 3.1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://people.freenet.de/kra/XawPlus/
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A replacement for Xaw with a nicer 3-D look and some extensions
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%X11BASE%%/lib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @cd ${WRKSRC} && ${FIND} . -name '*.orig' -delete
+
+do-configure:
+ ${REINPLACE_CMD} -e 's:%%X11BASE%%:${X11BASE}:' ${WRKSRC}/test/Makefile
+ -@${RM} -f ${WRKSRC}/test/Makefile.bak
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>