aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fox10/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-01-14 19:57:29 +0800
committerknu <knu@FreeBSD.org>2003-01-14 19:57:29 +0800
commitf37b2c3584ae340c365e019746a78dc358b4fdfc (patch)
tree3e80db16415fe623fe334762c89f9ccec8dd6a52 /x11-toolkits/fox10/Makefile
parent21841959ac690c4ec32a499811cc8838b58f15fc (diff)
downloadfreebsd-ports-graphics-f37b2c3584ae340c365e019746a78dc358b4fdfc.tar.gz
freebsd-ports-graphics-f37b2c3584ae340c365e019746a78dc358b4fdfc.tar.zst
freebsd-ports-graphics-f37b2c3584ae340c365e019746a78dc358b4fdfc.zip
Complete pkg-plist. FOX's configure script and Makefile's are just
terrible to deal with... Submitted by: bento
Diffstat (limited to 'x11-toolkits/fox10/Makefile')
-rw-r--r--x11-toolkits/fox10/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index a76ee864648..af6bbf3f0dc 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -41,6 +41,7 @@ PLIST_SUB= OLDFILE="@comment " \
USE_MESA= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
@@ -81,7 +82,9 @@ post-extract:
.endif
post-patch:
- ${PERL} -i -pe 's/^(SUBDIRS\s*=\s*).*/$$1utils include src \$${DOC}/' \
+ ${REINPLACE_CMD} -E 's/^(SUBDIRS[ ]*=[ ]*).*/\1utils include src $${DOC}/' \
${WRKSRC}/Makefile.in
+ ${FIND} ${WRKSRC} -name Makefile.in -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -E 's:\$$\(prefix\)/@PACKAGE@:$$(datadir)/doc/@PACKAGE@:'
.include <bsd.port.mk>