aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk--2/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>1998-09-01 06:01:46 +0800
committerkuriyama <kuriyama@FreeBSD.org>1998-09-01 06:01:46 +0800
commit472a270994dd31a9bfef703d728a5a9839e41dc0 (patch)
tree5be30358c1860c13eefa2d78e9e55a26221a1541 /x11-toolkits/gtk--2/Makefile
parent1ecdd0c416e9dc597795431d32f4694f2ab0ad13 (diff)
downloadfreebsd-ports-graphics-472a270994dd31a9bfef703d728a5a9839e41dc0.tar.gz
freebsd-ports-graphics-472a270994dd31a9bfef703d728a5a9839e41dc0.tar.zst
freebsd-ports-graphics-472a270994dd31a9bfef703d728a5a9839e41dc0.zip
C++ wrapper for gtk, a x11 graphics library
PR: ports/6704 Submitted by: Yukihiro Nakai <Nakai@technologist.com>
Diffstat (limited to 'x11-toolkits/gtk--2/Makefile')
-rw-r--r--x11-toolkits/gtk--2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/gtk--2/Makefile b/x11-toolkits/gtk--2/Makefile
new file mode 100644
index 00000000000..62ca273522e
--- /dev/null
+++ b/x11-toolkits/gtk--2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtk--
+# Version required: 0.9.14
+# Date created: 11 May 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= Gtk---0.9.14
+PKGNAME= gtk---0.9.14
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/gtk--/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gtk11\\.1\\.:${PORTSDIR}/x11-toolkits/gtk11
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+# Why gtk11 port renames gtk-config to gtk11-config? (patch-ae)
+#GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
+# for the future GNOME support
+#CONFIGURE_ARGS+= --with-gnome=${X11BASE}
+USE_GMAKE= yes
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>