aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk-engines2
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1999-01-31 03:42:47 +0800
committervanilla <vanilla@FreeBSD.org>1999-01-31 03:42:47 +0800
commitbbd053d8befe68b484107e7199dbba636c75c80b (patch)
treeb009bb966815ed24b5c0c7bc6d5e152723db565c /x11-toolkits/gtk-engines2
parent8d8a67f8e918c8b197bfd9a48109de23c9c92817 (diff)
downloadfreebsd-ports-graphics-bbd053d8befe68b484107e7199dbba636c75c80b.tar.gz
freebsd-ports-graphics-bbd053d8befe68b484107e7199dbba636c75c80b.tar.zst
freebsd-ports-graphics-bbd053d8befe68b484107e7199dbba636c75c80b.zip
Submitter say:
"The biggest change is to the gtk-engines port, where I've made the gtkrc files get the correct prefix. I've added the path to all the files, which may be overkill (it's only really needed for the pixmap theme), but was easier to do in an automated way, and provides a better example for people making their own themes." Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'x11-toolkits/gtk-engines2')
-rw-r--r--x11-toolkits/gtk-engines2/Makefile14
-rw-r--r--x11-toolkits/gtk-engines2/files/patch-ac56
2 files changed, 61 insertions, 9 deletions
diff --git a/x11-toolkits/gtk-engines2/Makefile b/x11-toolkits/gtk-engines2/Makefile
index bb7b87ade3d..6e23b568eed 100644
--- a/x11-toolkits/gtk-engines2/Makefile
+++ b/x11-toolkits/gtk-engines2/Makefile
@@ -3,7 +3,7 @@
# Date Created: 23 Dec 1998
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1999/01/26 02:22:29 foxfair Exp $
+# $Id: Makefile,v 1.4 1999/01/27 08:31:54 fenner Exp $
#
DISTNAME= gtk-engines-0.1
@@ -19,8 +19,16 @@ LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel \
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config"
+
+THEMES= metal notif pixmap redmond95
+
+post-patch:
+ @for theme in ${THEMES}; do \
+ cd ${WRKSRC}/$$theme/Theme/gtk; \
+ ${MV} gtkrc gtkrc.tmp; \
+ ${SED} -e s^%%PREFIX%%^${PREFIX}^g < gtkrc.tmp > gtkrc; \
+ done
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
diff --git a/x11-toolkits/gtk-engines2/files/patch-ac b/x11-toolkits/gtk-engines2/files/patch-ac
index 025dd87dff3..804b3532ab0 100644
--- a/x11-toolkits/gtk-engines2/files/patch-ac
+++ b/x11-toolkits/gtk-engines2/files/patch-ac
@@ -1,11 +1,55 @@
---- pixmap/Theme/gtk/gtkrc.orig Thu Dec 24 00:56:36 1998
-+++ pixmap/Theme/gtk/gtkrc Thu Dec 24 00:57:01 1998
-@@ -12,7 +12,7 @@
+--- metal/Theme/gtk/gtkrc.orig Sun Jan 31 03:04:18 1999
++++ metal/Theme/gtk/gtkrc Sun Jan 31 03:11:48 1999
+@@ -13,9 +13,9 @@
+ # testgtkrc2 sets all the buttons in the main window to blue by default
+ #include "testgtkrc2"
+
+-#module_path ".:/home/raster/themes"
++#module_path "%%PREFIX%%/share/themes"
+
+-pixmap_path "."
++pixmap_path "%%PREFIX%%/share/themes/Metal/gtk"
+ style "default"
+ {
+--- notif/Theme/gtk/gtkrc.orig Sun Jan 31 03:05:48 1999
++++ notif/Theme/gtk/gtkrc Sun Jan 31 03:11:41 1999
+@@ -13,9 +13,9 @@
# testgtkrc2 sets all the buttons in the main window to blue by default
#include "testgtkrc2"
--
-+pixmap_path "/usr/X11R6/share/themes/Pixmap/gtk"
- #module_path ".:/home/raster/themes"
+
+-#module_path ".:/home/raster/themes"
++#module_path "%%PREFIX%%/share/themes"
+
+-pixmap_path ".:/home/raster/themes"
++pixmap_path "%%PREFIX%%/share/themes/Notif/gtk"
+
+ style "default"
+ {
+--- pixmap/Theme/gtk/gtkrc.orig Thu Dec 17 01:05:37 1998
++++ pixmap/Theme/gtk/gtkrc Sun Jan 31 03:09:55 1999
+@@ -13,7 +13,9 @@
+ # testgtkrc2 sets all the buttons in the main window to blue by default
+ #include "testgtkrc2"
+
+-#module_path ".:/home/raster/themes"
++#module_path "%%PREFIX%%/share/themes"
++
++pixmap_path "%%PREFIX%%/share/themes/Pixmap/gtk"
style "eventbox" {
+ bg_pixmap[NORMAL] = "<parent>"
+--- redmond95/Theme/gtk/gtkrc.orig Sun Jan 31 03:10:29 1999
++++ redmond95/Theme/gtk/gtkrc Sun Jan 31 03:11:23 1999
+@@ -13,9 +13,9 @@
+ # testgtkrc2 sets all the buttons in the main window to blue by default
+ #include "testgtkrc2"
+
+-#module_path ".:/home/raster/themes"
++#module_path "%%PREFIX%%/share/themes"
+
+-pixmap_path ".:/home/raster/themes"
++pixmap_path "%%PREFIX%%/share/themes/Redmond95/gtk"
+
+ style "default"
+ {