aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/linux-f8-openmotif
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-10-04 11:26:26 +0800
committerpetef <petef@FreeBSD.org>2001-10-04 11:26:26 +0800
commited726b828364d3db41336e29ddddc78d4e2fe59d (patch)
treee3f3536db80e39f12465040da495df7d897550a7 /x11-toolkits/linux-f8-openmotif
parent1bade103b7702d50a9fa7ed6569db4b3c816f98f (diff)
downloadfreebsd-ports-graphics-ed726b828364d3db41336e29ddddc78d4e2fe59d.tar.gz
freebsd-ports-graphics-ed726b828364d3db41336e29ddddc78d4e2fe59d.tar.zst
freebsd-ports-graphics-ed726b828364d3db41336e29ddddc78d4e2fe59d.zip
Add linux-openmotif-2.1.30, Motif toolkit Linux libraries
PR: 30804 Submitted by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'x11-toolkits/linux-f8-openmotif')
-rw-r--r--x11-toolkits/linux-f8-openmotif/Makefile40
-rw-r--r--x11-toolkits/linux-f8-openmotif/distinfo.alpha1
-rw-r--r--x11-toolkits/linux-f8-openmotif/distinfo.i3861
-rw-r--r--x11-toolkits/linux-f8-openmotif/pkg-comment1
-rw-r--r--x11-toolkits/linux-f8-openmotif/pkg-descr1
-rw-r--r--x11-toolkits/linux-f8-openmotif/pkg-plist5
6 files changed, 49 insertions, 0 deletions
diff --git a/x11-toolkits/linux-f8-openmotif/Makefile b/x11-toolkits/linux-f8-openmotif/Makefile
new file mode 100644
index 00000000000..b224df234cd
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: linux-openmotif
+# Date created: 2001-09-24
+# Whom: Christian Weisgerber <naddy@mips.inka.de>
+#
+# $FreeBSD$
+
+PORTNAME= openmotif
+PORTVERSION= 2.1.30
+CATEGORIES= x11-toolkits linux
+MASTER_SITES= ftp://ftp.redhat.com/pub/%SUBDIR%/ \
+ ftp://ftp.sourceforge.net/pub/mirrors/redhat/%SUBDIR%/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.redhat.com/pub/%SUBDIR%/ \
+ ftp://ftp.uni-bayreuth.de/pub/redhat.com/%SUBDIR%/
+MASTER_SITE_SUBDIR= contrib/openmotif/linux-rpm
+PKGNAMEPREFIX= linux-
+EXTRACT_SUFX= -1_ICS.${MACHINE_ARCH}.rpm
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
+
+MAINTAINER= naddy@mips.inka.de
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
+
+ONLY_FOR_ARCHS= alpha i386
+USE_LINUX_PREFIX= yes
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+EXTRACT_FILES= usr/X11R6/lib/libMrm.so.2.1 \
+ usr/X11R6/lib/libUil.so.2.1 \
+ usr/X11R6/lib/libXm.so.2.1
+
+do-install:
+ cd ${PREFIX}; \
+ rpm2cpio ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} | \
+ cpio -idum -R ${LIBOWN}:${LIBGRP} ${EXTRACT_FILES}
+ chroot ${PREFIX} /sbin/ldconfig
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-f8-openmotif/distinfo.alpha b/x11-toolkits/linux-f8-openmotif/distinfo.alpha
new file mode 100644
index 00000000000..bec2322e897
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/distinfo.alpha
@@ -0,0 +1 @@
+MD5 (rpm/openmotif-2.1.30-1_ICS.alpha.rpm) = c56be19418719de0902e219d9b5bc966
diff --git a/x11-toolkits/linux-f8-openmotif/distinfo.i386 b/x11-toolkits/linux-f8-openmotif/distinfo.i386
new file mode 100644
index 00000000000..4149d766479
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/distinfo.i386
@@ -0,0 +1 @@
+MD5 (rpm/openmotif-2.1.30-1_ICS.i386.rpm) = 4eac14702af79a70945e1a4935e0fb12
diff --git a/x11-toolkits/linux-f8-openmotif/pkg-comment b/x11-toolkits/linux-f8-openmotif/pkg-comment
new file mode 100644
index 00000000000..916f768f49d
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/pkg-comment
@@ -0,0 +1 @@
+Motif toolkit Linux libraries
diff --git a/x11-toolkits/linux-f8-openmotif/pkg-descr b/x11-toolkits/linux-f8-openmotif/pkg-descr
new file mode 100644
index 00000000000..e669752e68f
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/pkg-descr
@@ -0,0 +1 @@
+Open Motif runtime libraries for the Linux emulation environment.
diff --git a/x11-toolkits/linux-f8-openmotif/pkg-plist b/x11-toolkits/linux-f8-openmotif/pkg-plist
new file mode 100644
index 00000000000..4585b0884c5
--- /dev/null
+++ b/x11-toolkits/linux-f8-openmotif/pkg-plist
@@ -0,0 +1,5 @@
+usr/X11R6/lib/libMrm.so.2.1
+usr/X11R6/lib/libUil.so.2.1
+usr/X11R6/lib/libXm.so.2.1
+@exec chroot %D /sbin/ldconfig
+@unexec chroot %D /sbin/ldconfig