aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-gtk/Makefile
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
commitcea38f8422a3eeac06b3ce4a5828580a5812d2cc (patch)
tree9703d7928f2f462fdf308bf7d14164f8f8459828 /x11-toolkits/py-gtk/Makefile
parent4495def283d3b8c777e1eb5b958cedb25b1aa16b (diff)
downloadfreebsd-ports-graphics-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.gz
freebsd-ports-graphics-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.zst
freebsd-ports-graphics-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.zip
Implement WANT_IMLIB and USE_IMLIB.
Diffstat (limited to 'x11-toolkits/py-gtk/Makefile')
-rw-r--r--x11-toolkits/py-gtk/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index 90fae792706..82b31e8aaba 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -14,22 +14,20 @@ DISTNAME= gnome-python-1.0.53
MAINTAINER= nectar@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- Imlib.5:${PORTSDIR}/graphics/imlib
+LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/pygtk
-GTK_CONFIG= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
+USE_IMLIB= yes
USE_PYTHON= yes
-CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG} PYTHON=${PYTHON_CMD}
USE_LIBTOOL= yes
-PLIST_COMPLETE= ${PKGDIR}/PLIST
+CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
-WRKSRC= ${WRKDIR}/${DISTNAME}/pygtk
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
.if !defined(NOPORTDOCS)
-PLIST= ${PLIST_COMPLETE}
post-install:
${MKDIR} ${EG_DST_DIR}
${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xvf -
@@ -43,7 +41,7 @@ PLIST= ${WRKDIR}/PLIST.nodocs
pre-install:
${RM} -f ${PLIST}
${GREP} -E -v '^(@dirrm )?(share/examples/)|(share/doc/)' \
- ${PLIST_COMPLETE} > ${PLIST}
+ ${PKGDIR}/PLIST > ${PLIST}
.endif
.include <bsd.port.mk>