aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-gtk2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-11-12 03:50:48 +0800
committermarcus <marcus@FreeBSD.org>2002-11-12 03:50:48 +0800
commit30c65ebf015f9c6583c5a1c2d43cf260a71c750e (patch)
tree23bea68725f4b1762b80dcb5ef26db03bcce896d /x11-toolkits/py-gtk2/Makefile
parentb8b6157940288d89b2d554bae83ca653aa12e575 (diff)
downloadfreebsd-ports-graphics-30c65ebf015f9c6583c5a1c2d43cf260a71c750e.tar.gz
freebsd-ports-graphics-30c65ebf015f9c6583c5a1c2d43cf260a71c750e.tar.zst
freebsd-ports-graphics-30c65ebf015f9c6583c5a1c2d43cf260a71c750e.zip
* Fix a crash in pygtk_generic_cell_renderer_get_size(). [1]
* Add an option to enable or disable pthread support. PR: 45150 Submitted by: Marc Recht <marc@informatik.uni-bremen.de> Obtained from: pygtk CVS [1]
Diffstat (limited to 'x11-toolkits/py-gtk2/Makefile')
-rw-r--r--x11-toolkits/py-gtk2/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 5df66d0ee0d..1b1fb14ee3a 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= gtk
PORTVERSION= 1.99.13
+PORTREVISION= 1
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/pygtk/1.99
@@ -29,6 +30,19 @@ USE_LIBTOOL= yes
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
+#
+# Use the same way as the Python port to determine if we want
+# threading support.
+#
+LIBC_R!= /sbin/ldconfig -r | grep c_r || true
+.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-thread
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
+.else
+CONFIGURE_ARGS+= --disable-thread
+.endif
+
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-build:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL