aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/ruby-tk
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /x11-toolkits/ruby-tk
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'x11-toolkits/ruby-tk')
-rw-r--r--x11-toolkits/ruby-tk/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11-toolkits/ruby-tk/Makefile b/x11-toolkits/ruby-tk/Makefile
index f446dcb2832..f54523d1957 100644
--- a/x11-toolkits/ruby-tk/Makefile
+++ b/x11-toolkits/ruby-tk/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: rubytk
-# Date created: 15 March 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: rubytk
+# Date created: 15 March 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -36,8 +36,8 @@ PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
BRANCH_NAME= 1.4
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
@@ -62,7 +62,7 @@ TK_LIB= tk${TK_VERSION}${TCL_JP}
TCL_DIR= `echo "${TCL_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
TK_DIR= `echo "${TK_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
-RUBY= ${LOCALBASE}/bin/ruby
+RUBY?= ${LOCALBASE}/bin/ruby
EXTS= tcltklib tk
do-configure:
@@ -81,14 +81,14 @@ do-install:
.for dir in ${EXTS}
@${ECHO_MSG} "Installing in ${dir}..."
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/sample/* ${EXAMPLESDIR}/${dir}
+.endif
.endfor
-
-post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/tcltklib/demo
${INSTALL_DATA} ${WRKSRC}/tcltklib/demo/* ${EXAMPLESDIR}/tcltklib/demo
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}/tcltklib
${INSTALL_DATA} ${WRKSRC}/tcltklib/*.euc ${DOCDIR}/tcltklib
.endif