aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-08 04:30:32 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-08 04:30:32 +0800
commit012a75d310d88a7a4737672880d4a36d7965c1ec (patch)
tree9055083ec1d6716841959905b9a2753b2dd0a55e /x11-toolkits
parente4b1ac22c41ad54c3fed15bbe2f189ab46cc472a (diff)
downloadfreebsd-ports-graphics-012a75d310d88a7a4737672880d4a36d7965c1ec.tar.gz
freebsd-ports-graphics-012a75d310d88a7a4737672880d4a36d7965c1ec.tar.zst
freebsd-ports-graphics-012a75d310d88a7a4737672880d4a36d7965c1ec.zip
Fix the file chooser in gtk-demo.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile5
-rw-r--r--x11-toolkits/gtk30/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 014cf40de69..cb39cee7ab8 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.8.6
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.8,} \
ftp://ftp.gtk.org/pub/gtk/v2.8/ \
@@ -95,6 +96,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/gtk/xdgmime/xdgmime.c
+# GnomeVFS needs pthread; gtk-demo may use GnomeVFS (via GtkFileChooser)
+ @${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
+ s|@LDFLAGS@|& ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/demos/gtk-demo/Makefile.in
pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 014cf40de69..cb39cee7ab8 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.8.6
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.8,} \
ftp://ftp.gtk.org/pub/gtk/v2.8/ \
@@ -95,6 +96,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/gtk/xdgmime/xdgmime.c
+# GnomeVFS needs pthread; gtk-demo may use GnomeVFS (via GtkFileChooser)
+ @${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
+ s|@LDFLAGS@|& ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/demos/gtk-demo/Makefile.in
pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*