aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
committermakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
commit071186fd6d22f1abd16554cae92bf26af9d1cb4e (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /x11-toolkits
parenteda1ae8e7cf50659cf0b55fefdcae532e6ad0405 (diff)
downloadfreebsd-ports-graphics-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.gz
freebsd-ports-graphics-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.zst
freebsd-ports-graphics-071186fd6d22f1abd16554cae92bf26af9d1cb4e.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/attica/Makefile2
-rw-r--r--x11-toolkits/gigi/Makefile2
-rw-r--r--x11-toolkits/sakura/Makefile2
-rw-r--r--x11-toolkits/shared-desktop-ontologies/Makefile2
-rw-r--r--x11-toolkits/termit/Makefile2
-rw-r--r--x11-toolkits/vtkfox/Makefile3
6 files changed, 6 insertions, 7 deletions
diff --git a/x11-toolkits/attica/Makefile b/x11-toolkits/attica/Makefile
index 66f4d1c303c..a76da3d1e22 100644
--- a/x11-toolkits/attica/Makefile
+++ b/x11-toolkits/attica/Makefile
@@ -15,7 +15,7 @@ USE_QT4= network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DATTICA_ENABLE_TESTS:BOOL=OFF
MAKE_JOBS_SAFE= yes
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index 1180820ab53..79b657c0ec4 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
freetype.9:${PORTSDIR}/print/freetype2
USE_GCC= 4.4+
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DBUILD_TUTORIALS:BOOL=OFF
USE_BZIP2= yes
USE_SDL= sdl
diff --git a/x11-toolkits/sakura/Makefile b/x11-toolkits/sakura/Makefile
index 13eeb911908..d9e60e8c0f2 100644
--- a/x11-toolkits/sakura/Makefile
+++ b/x11-toolkits/sakura/Makefile
@@ -16,7 +16,7 @@ COMMENT= A terminal emulator based on GTK and VTE
USE_GNOME= vte
USE_GETTEXT= yes
-USE_CMAKE= yes
+USES= cmake
USE_BZIP2= yes
USE_PKGCONFIG= build
diff --git a/x11-toolkits/shared-desktop-ontologies/Makefile b/x11-toolkits/shared-desktop-ontologies/Makefile
index c120dc26544..7e441fcf941 100644
--- a/x11-toolkits/shared-desktop-ontologies/Makefile
+++ b/x11-toolkits/shared-desktop-ontologies/Makefile
@@ -17,7 +17,7 @@ CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:PATH="libdata/pkgconfig/"
INSTALL_TARGET= install
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_GNOME= pkgconfig
post-patch:
diff --git a/x11-toolkits/termit/Makefile b/x11-toolkits/termit/Makefile
index c8db9827ab2..c5d39bc2562 100644
--- a/x11-toolkits/termit/Makefile
+++ b/x11-toolkits/termit/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_PKGCONFIG= build
USE_ICONV= yes
USE_LUA= yes
diff --git a/x11-toolkits/vtkfox/Makefile b/x11-toolkits/vtkfox/Makefile
index 8b770436fe9..7c43d381d0d 100644
--- a/x11-toolkits/vtkfox/Makefile
+++ b/x11-toolkits/vtkfox/Makefile
@@ -33,8 +33,7 @@ LIB_DEPENDS+= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
CMAKE_ARGS+= -DFOX17:BOOL=TRUE
.endif
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
USE_LDCONFIG= yes
PLIST_FILES= include/vtkfox/FXVTKCanvas.h \