aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-08-11 04:15:00 +0800
committermezz <mezz@FreeBSD.org>2007-08-11 04:15:00 +0800
commit1445a2f907a6facfa526197a04778ae49dae41bc (patch)
treed9e50a619dd059f8083bbd1159a2dc2633e18b15 /x11-toolkits
parent054ed097dc98fef86a02c04045e8f64782878f18 (diff)
downloadfreebsd-ports-graphics-1445a2f907a6facfa526197a04778ae49dae41bc.tar.gz
freebsd-ports-graphics-1445a2f907a6facfa526197a04778ae49dae41bc.tar.zst
freebsd-ports-graphics-1445a2f907a6facfa526197a04778ae49dae41bc.zip
Add a check on if scintilla built with GTK+2 then mark it as IGNORE. It
required to have scintilla build with GTK+1 (which is by default). PR: ports/115394 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtkscintilla/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-toolkits/gtkscintilla/Makefile b/x11-toolkits/gtkscintilla/Makefile
index 7cbc60b76c9..eb55ebe1545 100644
--- a/x11-toolkits/gtkscintilla/Makefile
+++ b/x11-toolkits/gtkscintilla/Makefile
@@ -22,6 +22,12 @@ USE_GMAKE= yes
USE_GNOME= gtk12
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if !exists(${PREFIX}/include/scintilla/.scintilla-gtk1)
+IGNORE= requires x11-toolkits/scintilla to be built with GTK+1
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/scintilla
${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/scintilla
@@ -29,4 +35,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/libgtkscintilla.so.0 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libgtkscintilla.so.0 ${PREFIX}/lib/libgtkscintilla.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>