aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-29 01:49:34 +0800
committerpawel <pawel@FreeBSD.org>2011-10-29 01:49:34 +0800
commit3cda8bc65ca3a3d035b5c66543ea840d25d2a3ff (patch)
tree08e1c79cdc1d3c54430903d703bc85cb0d0c435a /x11-toolkits
parent74df13b6571589a2646ae905546e369d9f43ee69 (diff)
downloadfreebsd-ports-graphics-3cda8bc65ca3a3d035b5c66543ea840d25d2a3ff.tar.gz
freebsd-ports-graphics-3cda8bc65ca3a3d035b5c66543ea840d25d2a3ff.tar.zst
freebsd-ports-graphics-3cda8bc65ca3a3d035b5c66543ea840d25d2a3ff.zip
- Use correct USE_AUTOTOOLS libtool expression
- Fix build PR: ports/162040 Submitted by: Laurent Berthelet <laurent@ospowa.com>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtkextra2/Makefile2
-rw-r--r--x11-toolkits/gtkextra2/files/patch-Makefile.in16
-rw-r--r--x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c11
3 files changed, 28 insertions, 1 deletions
diff --git a/x11-toolkits/gtkextra2/Makefile b/x11-toolkits/gtkextra2/Makefile
index 04efbe1a074..bd0284e55fd 100644
--- a/x11-toolkits/gtkextra2/Makefile
+++ b/x11-toolkits/gtkextra2/Makefile
@@ -16,7 +16,7 @@ COMMENT= A useful widget set complementary to GTK+ 2.0
USE_GNOME= gtk20 gnomehack
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
LATEST_LINK= gtkextra2
diff --git a/x11-toolkits/gtkextra2/files/patch-Makefile.in b/x11-toolkits/gtkextra2/files/patch-Makefile.in
new file mode 100644
index 00000000000..04ee2fb5154
--- /dev/null
+++ b/x11-toolkits/gtkextra2/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- gtkextra/Makefile.in.orig 2011-10-27 00:29:46.287956897 +0200
++++ gtkextra/Makefile.in 2011-10-27 00:30:31.199394384 +0200
+@@ -1028,11 +1028,11 @@
+ $(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
+
+ $(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
++ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ $(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
++ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
diff --git a/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c b/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c
new file mode 100644
index 00000000000..459335b5475
--- /dev/null
+++ b/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c
@@ -0,0 +1,11 @@
+--- gtkextra/gtkcolorcombo.c.orig 2011-10-27 00:08:40.655552360 +0200
++++ gtkextra/gtkcolorcombo.c 2011-10-27 00:09:03.934648236 +0200
+@@ -146,7 +146,7 @@
+ GTK_CLASS_TYPE(object_class),
+ GTK_SIGNAL_OFFSET(GtkColorComboClass,
+ changed),
+- gtkextra_VOID__INT_BOXED,
++ gtkextra_VOID__BOXED_BOXED,
+ GTK_TYPE_NONE,
+ 2, GTK_TYPE_INT, GDK_TYPE_COLOR);
+
> supported. - Display pkg-message when installing from the port. Approved by: tabthorpe (mentor) Feature safe: yes * - Fix build on 7.X amd64 and 6.X everywhere.avilla2010-02-1910-31/+231 | | | | | | | | - Fix pidfile deletion in the rc.d script. - Add pkg-message about local startup of the daemon. Approved by: tabthorpe (mentor) Feature safe: yes * Presenting KDE 4.3.5 for FreeBSD. The official release notes for thismiwi2010-02-0715-45/+15 | | | | | | | release can be found at http://kde.org/announcements/announce-4.3.5.php. KDE 4.3.5, the last bugfix release in 4.3.x series. We'd like to say thanks to all helpers and submitters. * - Mark BROKEN on 6.X everywhere and on 7.X amd64pav2010-02-061-0/+8 | | | | Reported by: pointyhat * - update to jpeg-8dinoex2010-02-0516-6/+16 | * - Update my e-mail address in the ports I maintain.avilla2010-01-271-1/+1 | | | | Approved by: miwi (mentor) * The FreeBSD KDE team is pleased to announce Qt-4.6.1 for FreeBSD.makc2010-01-223-17/+21 | * - speech-dispatcher: try fix building on FreeBSD < 8.0fluffy2010-01-188-1/+301 | | | | | | PR: 142869 Submitted by: Alberto Villa (maintainer) Approved by: miwi, tabthorpe (mentors implicit) * - Add speech-dispatcherfluffy2010-01-0816-0/+426 | | | | | | | | | | | | | | Speech Dispatcher is a device independent layer for speech synthesis, developed with the goal of making the usage of speech synthesis easier for application programmers. It takes care of most of the tasks necessary to solve in speech enabled applications. What is a very high level GUI library to graphics, Speech Dispatcher is to speech synthesis. PR: 142436 Submitted by: Alberto Villa Tested by: myself Approved by: miwi, tabthorpe (mentors implicit) * Update to 2.28.3ahze2010-01-042-4/+4 | * Update to 2.28.2.kwm2009-12-193-4/+22 | * Update to 2.28.2.marcus2009-12-182-4/+4 | * The FreeBSD KDE is please to announce the release of KDE 4.3.4,miwi2009-12-025-15/+15 | | | | | | | a bugfix, translation and maintenance update. Release note can be found at http://kde.org/announcements/announce-4.3.4.php We'd like to say thanks to all helpers and submitters. * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-2924-129/+245 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.3miwi2009-11-2710-25/+15 | | | | | | | | | | | | | for FreeBSD. For lists of bugfixes and improvements please see: http://www.kde.org/announcements/changelogs/changelog4_3_1to4_3_2.php http://www.kde.org/announcements/changelogs/changelog4_3_2to4_3_3.php The KDE FreeBSD team would like to say thanks to all the helpers and submitters. Tested by: pointyhat-exp-run (myself) * - Update to Qt-4.5miwi2009-11-272-6/+0 | | | | | | | The KDE FreeBSD team would like to say thanks to all the helpers and submitters. Tested by: pointyhat-exp-run (myself) * - Mark MAKE_JOBS_UNSAFEpav2009-11-201-0/+1 | | | | Reported by: pointyhat * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-025-15/+15 | | | | | | | | a bugfix, translation and maintenance update. Release note can be found at http://kde.org/announcements/announce-4.3.1.php We would like to thank all our contributors and testers. My personal thanks to miwi and makc for coaching me through my first KDE commit. * - Switch SourceForge ports to the new File Release System: categories ↵amdmi32009-08-221-1/+1 | | | | starting with A * Fix the plist when doxygen is installed.marcus2009-08-161-0/+11 | | | | | PR: 137585 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com> * Mk/bsd.kde4.mk:makc2009-08-105-15/+0 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - rework KDE4_BUILDENV All ports: - remove needless post-extract target - make patches relative to ${PATCH_WRKSRC} - clean up - bump PORTREVISION when required databases/akonadi: - replace dependency on boost-python-libs with boost-libs (finally, boost-pyhton does not conflict with boost \o/) deskutils/kdepim*: - replace boost-python-libs with boost-libs - reduce dependencies - respect PREFIX - fix build with qt3 installed misc/kdeedu4: - add dependency on astro/xplanet (for KStars) misc/kdeutils4: - add dependency on devel/qca (for okteta) - make dependency on kdebase non-optional multimedia/kdemultimedia4: - add optional support for PulseAudio x11/kdebase4: - remove needless dependency on kdebase4-runtime x11/kdebase4-runtime, x11/kdebase4-workspace - remove extra CMAKE_ARGS to fix build for qt3/kde3 users x11/kdelibs4 - remove needless dependencies - remove extra CMAKE_ARGS to fix build for qt3/kde3 users * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-0515-30/+35 | | | | | | | | | | for FreeBSD. The official KDE 4.3.0 (Codename: "Caizen") release notes can be found at: http://kde.org/announcements/4.3/index.php. We'd like to say thanks to all helpers and submitters. Tested by: pointyhat-exp-run (pav/miwi) * - s/MAKE_JOBS_SAVE/MAKE_JOBS_SAFEmiwi2009-08-051-1/+1 | | | | Reported by: pg * - Update Qt4 to 4.5.2miwi2009-08-052-3/+4 | | | | | | | The KDE FreeBSD team would like to say thanks to all the helpers and submitters. Tested by: pointyhat-exp-run (pav/miwi) * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-033-3/+3 | | | | | | | | | | | | | | | | | | -Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr * Update to 0.15.8.marcus2009-08-022-4/+4 | * - bump all port that indirectly depends on libjpeg and have not yet been ↵dinoex2009-07-3115-5/+15 | | | | | | bumped or updated Requested by: edwin * Update to 0.15.7.marcus2009-07-073-4/+7 | * Update to 2.26.3.avl2009-07-032-4/+4 | | | | | Reviewed by: mezz (GNOME team) Approved by: glarkin (mentor) * Update to 2.26.3.avl2009-07-013-4/+7 | | | | | Reviewed by: mezz (GNOME team) Approved by: tabthorpe (mentor) * Fix build with custom LOCALBASEitetcu2009-06-171-0/+2 | | | | | | | Submitted by: Sahil Tandon Reported by: QATty Approved by: portmgr (itetcu@) No cookie for: maintainer * - Assign all unmaintained ruby ports to ruby@,stas2009-06-161-1/+1 | | | | so people will know where to send questions to. * The KDE FreeBSD team is pleased to announce KDE 4.2.4, the last bugfixmiwi2009-06-035-15/+15 | | | | | | release in 4.2.x series. The official KDE 4.2.4 release changelog can be found at: http://www.kde.org/announcements/changelogs/changelog4_2_3to4_2_4.php. * . add linux-f10 ports to the rank of CONFLICTS for linux-fc4 ports;bsam2009-06-031-2/+2 | | | | . bump PORTREVISIONs. * . add CONFLICTS to linux-f8 infrastructure ports;bsam2009-06-031-0/+3 | | | | . bump PORTREVISIONs. * Here are new Linux Fedora 10 infrastructure ports.bsam2009-06-024-20/+24 | | | | | | | | | | | | | | | | | | | | | | | | Those ports are intended to be used with 8-CURRENT at least with SVN r192206. If you want to switch to linux-f10 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=f10 OVERRIDE_LINUX_NONBASE_PORTS=f10 An upgrading procedure is shown at /usr/ports/UPDATING, entries 20090401 and 20070327. For the first time all tested linux ports work as expected(!): . acroread8; . google-earth; . skype; . seamonkey. Many thanks for kernel folks who really did the main work (and I wrote only some lines of ports). There is a good chance that those ports may become a default for 8.0-RELEASE. Please, test and report back to emulation@ ML. * Update to 2.26.2.marcus2009-05-196-8/+50 | * Update KDE ports to 4.2.3makc2009-05-105-15/+15 | | | | | | | | | | | | | | | | | | | | | | | | See original release announcement for details: http://kde.org/announcements/announce-4.2.3.php New ports: devel/kdebindings4: Meta port of KDE bindings for C#, Java, PHP, Python and Ruby. Currently only Python bindings are supported. devel/kdebindings4-python, devel/kdebindings4-python-krosspython, devel/kdebindings4-python-pykde4: Python bindings for KDE. print/kdeutils4-printer-applet: printer-applet is a system tray utility. It shows current print jobs, shows printer warnings and errors and shows when printers that have been plugged in for the first time are being auto-configured by hal-cups-utils. It replaces kjobviewer in KDE 3. print/system-config-printer-kde A port of Gnome system-config-printer to KDE. * Update to 4.10.1.marcus2009-05-103-4/+23 | * mark as MAKE_JOBS_UNSAFEmakc2009-04-255-5/+5 | * Presenting GNOME 2.26.1 for FreeBSD.kwm2009-04-244-10/+10 | | | | Approved by: portmgr (marcus) * Update to 0.15.6.marcus2009-04-122-4/+4 | * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-1023-53/+219 | | | | | | | | | | | | | http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach. * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-0210-20/+20 | | | | | | | | | | for FreeBSD. The official KDE 4.2.2 release changelog can be found at: http://www.kde.org/announcements/changelogs/changelog4_2_1to4_2_2.php. Also mark some ports MAKE_JOBS_SAFE. New Ports: misc/kde4-l10n-sk - Slovak * Here are new Linux Fedora 8 infrastructure ports.bsam2009-04-017-44/+75 | | | | | | | | | | | | | | | The recommended version of FreeBSD to use them is 8-CURRENT. FreeBSD-7.x is not fully compatible with compat.linux.osrelease 2.6.16. Some syscalls cannot be MFCed due to native FreeBSD ABI breakage. Usage (and package building): 1. define compat.linux.osrelease=2.6.16; 2. add following variables to /etc/make.conf: . OVERRIDE_LINUX_BASE_PORT=f8; . OVERRIDE_LINUX_NONBASE_PORTS=f8. Approved by: bsam (me) ;-) * Finish repocopies of new linux-f8 infrastructure ports:bsam2009-04-011-1/+3 | | | | | | . add CONFLICTS to 47 original ports; . bump PORTREVISIONs for all of them; . pet portlint for 2-3 ports (misplaced PORTREVISION). * bump PORTREVISION after cmake updatemakc2009-03-255-0/+5 | * Release these ports into wild. I don't have time for these ports anymore. I ammezz2009-03-191-1/+1 | | | | keeping maintain two ports that don't require a lot of time to take care of. * Update to 0.15.5.marcus2009-03-153-4/+7 | * Update KDE to 4.2.1.makc2009-03-095-15/+15 | | | | | | | multimedia/phonon port has been split into phonon itself, phonon-xine and phono-gstreamer backends. After updating phonon port you have to install at least one backend. phonon-xine backend is recommended for KDE. * Update to 0.0.9.mva2009-03-082-4/+4 | | | | Approved by: miwi (mentor) * Update to 0.4.25.marcus2009-02-232-4/+4 | * Update to 2.24.4.kwm2009-02-213-7/+7 | * Updated my mail address to use @FreeBSD.org now.mva2009-02-202-2/+2 | | | | Approved by: miwi (co-mentor), beech (mentor)