aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-07-27 21:25:14 +0800
committerkwm <kwm@FreeBSD.org>2013-07-27 21:25:14 +0800
commit551b859bb9015b0a0b491904a0872ddc45b1e5f2 (patch)
tree11260da69da4b4933938c35719be28067b24ef5b /x11-toolkits
parent7912532389f10b2eb5680da2ad3e27d123a4279d (diff)
downloadfreebsd-ports-graphics-551b859bb9015b0a0b491904a0872ddc45b1e5f2.tar.gz
freebsd-ports-graphics-551b859bb9015b0a0b491904a0872ddc45b1e5f2.tar.zst
freebsd-ports-graphics-551b859bb9015b0a0b491904a0872ddc45b1e5f2.zip
Add patch to fix build with clang.
Use USES=gmake and pathfix Approved by: maintainer (implicit)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/libgnomeuimm/Makefile10
-rw-r--r--x11-toolkits/libgnomeuimm/files/patch-examples_iconlist_iconlist.cc10
2 files changed, 13 insertions, 7 deletions
diff --git a/x11-toolkits/libgnomeuimm/Makefile b/x11-toolkits/libgnomeuimm/Makefile
index c9cf9d882c5..a9a1864ec67 100644
--- a/x11-toolkits/libgnomeuimm/Makefile
+++ b/x11-toolkits/libgnomeuimm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libgnomeuimm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
-#
PORTNAME= libgnomeuimm
PORTVERSION= 2.0.0
@@ -21,8 +17,8 @@ LIB_DEPENDS= gnomemm-2.0:${PORTSDIR}/x11/libgnomemm \
glademm-2.0:${PORTSDIR}/devel/libglademm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USE_GMAKE= yes
-USE_GNOME= gnomehack libgnomeui
+USES= gmake pathfix
+USE_GNOME= libgnomeui
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11-toolkits/libgnomeuimm/files/patch-examples_iconlist_iconlist.cc b/x11-toolkits/libgnomeuimm/files/patch-examples_iconlist_iconlist.cc
new file mode 100644
index 00000000000..8711046f9f4
--- /dev/null
+++ b/x11-toolkits/libgnomeuimm/files/patch-examples_iconlist_iconlist.cc
@@ -0,0 +1,10 @@
+--- examples/iconlist/iconlist.cc.orig 2013-07-27 15:02:04.000000000 +0200
++++ examples/iconlist/iconlist.cc 2013-07-27 15:02:40.000000000 +0200
+@@ -58,6 +58,7 @@
+ show_all_children ();
+ }
+
++int
+ main (int argc, char *argv[])
+ {
+ Gnome::Main kit ("Iconlist", "0.0.0", Gnome::UI::module_info_get(), argc, argv);