aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2015-09-01 03:38:23 +0800
committerdbn <dbn@FreeBSD.org>2015-09-01 03:38:23 +0800
commit5cef7aece3322f37a8806606f2cdd0e318e91c7e (patch)
treee38ad343bb0776e7eeb5b7e1a6d397c3b069282f /x11-toolkits
parent15026c16ef00ed26ace1cf808daaf173d51b5827 (diff)
downloadfreebsd-ports-graphics-5cef7aece3322f37a8806606f2cdd0e318e91c7e.tar.gz
freebsd-ports-graphics-5cef7aece3322f37a8806606f2cdd0e318e91c7e.tar.zst
freebsd-ports-graphics-5cef7aece3322f37a8806606f2cdd0e318e91c7e.zip
lang/pypy: update to 2.6.1
Changes: - Add external cffi ports (a la python): - databases/pypy-gdbm - databases/pypy-sqlite3 - x11-toolkits/pypy-tkinter - Add bsd.pypy.mk for consistency between pypy ports. - Add bsd.pypy.cffi.mk for consistency with external cffi ports. - Switch back to using $PREFIX/pypy-X.Y (the '-' separator is required to differentiate between lang/pypy and lang/pypy3) - Remove all patches (upstreamed, see announcement below) ChangeLog: - Bug Fixes - Revive non-SSE2 support - Fixes for detaching _io.Buffer* - Clear up contention in the garbage collector between trace-me-later and pinning - Issues reported with our previous release were resolved after reports from users on our issue tracker at https://bitbucket.org/pypy/pypy/issues or on IRC at #pypy. - New features: - cffi was updated to version 1.3 - The python stdlib was updated to 2.7.10 from 2.7.9 - vmprof now supports multiple threads - The translation process builds cffi import libraries for some stdlib packages, which should prevent confusion when package.py is not used - better support for gdb debugging - FreeBSD should be able to translate PyPy "out of the box" with no patches - Numpy: - Better support for record dtypes, including the align keyword - Implement casting and create output arrays accordingly (still missing some corner cases) - Support creation of unicode ndarrays - Better support ndarray.flags - Support axis argument in more functions - Refactor array indexing to support ellipses - Allow the docstrings of built-in numpy objects to be set at run-time - Support the buffered nditer creation keyword - Performance improvements: - Delay recursive calls to make them non-recursive - Skip loop unrolling if it compiles too much code - Tweak the heapcache - Add a list strategy for lists that store both floats and 32-bit integers. The latter are encoded as nonstandard NaNs. Benchmarks show that the speed of such lists is now very close to the speed of purely-int or purely-float lists. - Simplify implementation of ffi.gc() to avoid most weakrefs - Massively improve the performance of map() with more than one sequence argument Differential Revision: https://reviews.freebsd.org/D3285
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/pypy-tkinter/Makefile17
-rw-r--r--x11-toolkits/pypy-tkinter/pkg-descr1
3 files changed, 19 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 63198c4bd56..3e8632d4e79 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -204,6 +204,7 @@
SUBDIR += py-wxPython28-unicode
SUBDIR += py-wxPython30
SUBDIR += py-xlib
+ SUBDIR += pypy-tkinter
SUBDIR += qt4-declarative
SUBDIR += qt4-gui
SUBDIR += qt4pas
diff --git a/x11-toolkits/pypy-tkinter/Makefile b/x11-toolkits/pypy-tkinter/Makefile
new file mode 100644
index 00000000000..47ace98f149
--- /dev/null
+++ b/x11-toolkits/pypy-tkinter/Makefile
@@ -0,0 +1,17 @@
+# Created by: David Naylor <dbn@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tkinter
+PORTVERSION= ${PYTHON_PORTVERSION}
+CATEGORIES= x11-toolkits python
+
+MAINTAINER= dbn@FreeBSD.org
+COMMENT= PyPy bindings to the Tk widget set
+
+USES= tk
+
+CFFI_MODULE= _tkinter/tklib
+CFFI_NAME= tkffi
+
+.include "${.CURDIR}/../../lang/pypy/bsd.pypy.cffi.mk"
+.include <bsd.port.mk>
diff --git a/x11-toolkits/pypy-tkinter/pkg-descr b/x11-toolkits/pypy-tkinter/pkg-descr
new file mode 100644
index 00000000000..eae0c770439
--- /dev/null
+++ b/x11-toolkits/pypy-tkinter/pkg-descr
@@ -0,0 +1 @@
+PyPy bindings to the Tk widget set.