aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-13 19:23:18 +0800
committeredwin <edwin@FreeBSD.org>2003-04-13 19:23:18 +0800
commit68d4ca97c8a07b88ebe24a1e9f8608eac0da0452 (patch)
tree7136d3e9613d316f8315eb87764832fbe79aef6c /x11-toolkits
parent06c6ae10229782e4272ce93311894cc6ea5b7711 (diff)
downloadfreebsd-ports-graphics-68d4ca97c8a07b88ebe24a1e9f8608eac0da0452.tar.gz
freebsd-ports-graphics-68d4ca97c8a07b88ebe24a1e9f8608eac0da0452.tar.zst
freebsd-ports-graphics-68d4ca97c8a07b88ebe24a1e9f8608eac0da0452.zip
Fix build for x11-toolkits/php-gtk
Due to incorrect build dependencies, php-gtk failed to build (as reported by bento). This patch fixes BUILD_DEPENDS and corrects another small bug (pre-configure wouldn't be called under certain circumstances). PR: ports/50854 Submitted by: Alex Kiesel <kiesel@schlund.de>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/php-gtk/Makefile12
-rw-r--r--x11-toolkits/php-gtk2/Makefile12
2 files changed, 10 insertions, 14 deletions
diff --git a/x11-toolkits/php-gtk/Makefile b/x11-toolkits/php-gtk/Makefile
index f92df3526dc..07df6f6920a 100644
--- a/x11-toolkits/php-gtk/Makefile
+++ b/x11-toolkits/php-gtk/Makefile
@@ -18,14 +18,14 @@ COMMENT= An extension to use gtk in PHP-applications
# automake-1.5 installed - what a mess
BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
automake14:${PORTSDIR}/devel/automake14 \
- autoconf:${PORTSDIR}/devel/autoconf213 \
- ${LOCALBASE}/bin/phpize:${PORTSDIR}/www/mod_php4
+ autoconf:${PORTSDIR}/devel/autoconf \
+ autoconf213:${PORTSDIR}/devel/autoconf213 \
+ phpize:${PORTSDIR}/www/mod_php4
RUN_DEPENDS= php:${PORTSDIR}/www/mod_php4
# Don't call autoconf directly, ./buildconf does this
GNU_CONFIGURE= yes
USE_AUTOCONF= no
-USE_LIBTOOL= no
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOMENG= yes
@@ -75,11 +75,9 @@ pre-everything::
@${ECHO_MSG} '* *'
@${ECHO_MSG} '*********************************************************'
-post-patch-script:
- @${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
- (cd ${WRKSRC} && ./buildconf)
-
pre-configure:
+ @${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
+ @(cd ${WRKSRC} && ./buildconf)
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor
diff --git a/x11-toolkits/php-gtk2/Makefile b/x11-toolkits/php-gtk2/Makefile
index f92df3526dc..07df6f6920a 100644
--- a/x11-toolkits/php-gtk2/Makefile
+++ b/x11-toolkits/php-gtk2/Makefile
@@ -18,14 +18,14 @@ COMMENT= An extension to use gtk in PHP-applications
# automake-1.5 installed - what a mess
BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
automake14:${PORTSDIR}/devel/automake14 \
- autoconf:${PORTSDIR}/devel/autoconf213 \
- ${LOCALBASE}/bin/phpize:${PORTSDIR}/www/mod_php4
+ autoconf:${PORTSDIR}/devel/autoconf \
+ autoconf213:${PORTSDIR}/devel/autoconf213 \
+ phpize:${PORTSDIR}/www/mod_php4
RUN_DEPENDS= php:${PORTSDIR}/www/mod_php4
# Don't call autoconf directly, ./buildconf does this
GNU_CONFIGURE= yes
USE_AUTOCONF= no
-USE_LIBTOOL= no
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOMENG= yes
@@ -75,11 +75,9 @@ pre-everything::
@${ECHO_MSG} '* *'
@${ECHO_MSG} '*********************************************************'
-post-patch-script:
- @${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
- (cd ${WRKSRC} && ./buildconf)
-
pre-configure:
+ @${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
+ @(cd ${WRKSRC} && ./buildconf)
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor