aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-06 23:56:56 +0800
committerknu <knu@FreeBSD.org>2002-12-06 23:56:56 +0800
commit69dae38759b16b71c8e6f578ed9c96703baccf67 (patch)
tree5c35dc00a27d7a072eab4537d4cad7ed3299d0d6 /x11-toolkits
parent9254d564964553b553d5f8087bbf36595e518f8d (diff)
downloadfreebsd-ports-graphics-69dae38759b16b71c8e6f578ed9c96703baccf67.tar.gz
freebsd-ports-graphics-69dae38759b16b71c8e6f578ed9c96703baccf67.tar.zst
freebsd-ports-graphics-69dae38759b16b71c8e6f578ed9c96703baccf67.zip
Apply the new C++ patch to all of the ruby-qt2* ports and unbreak them.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/ruby-qt2/Makefile2
-rw-r--r--x11-toolkits/ruby-qt2/Makefile.common6
2 files changed, 5 insertions, 3 deletions
diff --git a/x11-toolkits/ruby-qt2/Makefile b/x11-toolkits/ruby-qt2/Makefile
index acdffda1955..f583a265a57 100644
--- a/x11-toolkits/ruby-qt2/Makefile
+++ b/x11-toolkits/ruby-qt2/Makefile
@@ -31,8 +31,6 @@ post-extract:
${FIND} ${WRKSRC} '(' -name .cvsignore -o -name a.out ')' -delete
post-patch:
- ${GREP} -Frl 'typedef VALUE (*VALUEFUNC)();' ${WRKSRC} | \
- ${XARGS} ${RUBY} -i -pe 'sub(/typedef VALUE \(\*VALUEFUNC\)\(\);/, "typedef VALUE (*VALUEFUNC)(...);")'
${RUBY} -i -pe 'sub %r"/usr/X11\b", "${X11BASE}"' ${WRKSRC}/lib/qt2.rb
post-install:
diff --git a/x11-toolkits/ruby-qt2/Makefile.common b/x11-toolkits/ruby-qt2/Makefile.common
index 81dbcebd7ea..e08a6c30fd1 100644
--- a/x11-toolkits/ruby-qt2/Makefile.common
+++ b/x11-toolkits/ruby-qt2/Makefile.common
@@ -19,7 +19,11 @@ RUBY_QT2_CONFIGURE_ARGS= \
MD5_FILE= ${RUBY_QT2_PORTDIR}/distinfo
-post-patch: post-patch-cflags
+post-patch: post-patch-cflags post-patch-c++
post-patch-cflags:
${RUBY} -i -pe '~ /^\$$CFLAGS\b.*/ and $$_.sub!(/-O\w*/, "")' ${WRKSRC}/extconf.rb
+
+post-patch-c++:
+ ${GREP} -Frl 'typedef VALUE (*VALUEFUNC)();' ${WRKSRC} | \
+ ${XARGS} ${RUBY} -i -pe 'sub(/typedef VALUE \(\*VALUEFUNC\)\(\);/, "typedef VALUE (*VALUEFUNC)(...);")'