aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-04 02:16:07 +0800
committermakc <makc@FreeBSD.org>2013-02-04 02:16:07 +0800
commit7ab84c06519afffae15f6c14b92743f8991311de (patch)
tree2cb4abebbb7836188618ba34b415099af9acc1de /x11-toolkits
parentb35e2d02eb79155967699a2df3d74240374730cd (diff)
downloadfreebsd-ports-graphics-7ab84c06519afffae15f6c14b92743f8991311de.tar.gz
freebsd-ports-graphics-7ab84c06519afffae15f6c14b92743f8991311de.tar.zst
freebsd-ports-graphics-7ab84c06519afffae15f6c14b92743f8991311de.zip
KDE/FreeBSD team presents:
SIP 4.14.3 QScintilla 2.7 PyQt 4.9.6 The area51 repository features commits by jhale and myself. Changes: - Trim Makefile header - Convert to new option framework
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile41
-rw-r--r--x11-toolkits/py-qt4-gui/pkg-descr2
-rw-r--r--x11-toolkits/py-qt4-gui/pkg-plist4
3 files changed, 25 insertions, 22 deletions
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index 5fe97ce7c33..47dbca4e99d 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: py-qt4-gui
-# Date created: 2007-02-20
-# Whom: Danny Pansters <danny@ricin.com>
-#
+# Created by: Danny Pansters <danny@ricin.com>
# $FreeBSD$
PORTNAME= gui
PORTVERSION= ${PYQT4_VERSION}
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
@@ -25,37 +21,40 @@ USE_PYTHON= 2.5+
USE_QT4= gui imageformats_run inputmethods_run iconengines_run \
qmake_build moc_build
-OPTIONS= API "Install QtGui API for QScintilla2" on
+OPTIONS_DEFINE= API
+OPTIONS_DEFAULT=API
+API_DESC= Install QtGui API for QScintilla2
-PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
+PATCHDIR= ${.CURDIR}/../../devel/py-qt4-core/files
OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
QSCIDIR= ${PREFIX}/share/qt4/qsci
-CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
ARGS= -b ${PREFIX}/bin \
-d ${PYTHONPREFIX_SITELIBDIR} \
-p ${PREFIX}/${QT_PLUGINDIR_REL} \
-q ${QMAKE} \
--confirm-license \
--sipdir ${SIPDIR} \
- --enable QtGui
+ --enable QtGui \
+ CC="${CC}" CXX="${CXX}" LINK="${CXX}" LINK_SHLIB="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-.if defined(WITH_DEBUG)
-ARGS+= --debug --trace
-.endif
-
-.include "../../devel/py-sip/files/bsd.pyqt.mk"
+.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.options.mk>
-.if defined(WITHOUT_API)
+.if empty(PORT_OPTIONS:MAPI)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
+.if defined(WITH_DEBUG)
+ARGS+= --debug --trace
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
@@ -65,10 +64,10 @@ do-configure:
${PYTHON_CMD} configure.py ${ARGS}
post-configure:
- ${REINPLACE_CMD} -e 's|mkspecs/freebsd-g++|share/qt4/mkspecs/freebsd-g++|'\
- -e 's|CC = cc|CC = ${CC}|'\
- -e 's|CXX = c++|CXX = ${CXX}|'\
- -e 's|LINK = c++|LINK = ${CXX}|'\
- ${WRKSRC}/QtGui/Makefile
+ ${REINPLACE_CMD} -e 's|^CC.*|CC = ${CC}|' \
+ -e 's|^CXX.*|CXX = ${CXX}|' \
+ -e 's|^LINK.*|LINK = ${CXX}|' \
+ -e 's|^CFLAGS|CXXFLAGS|' \
+ ${WRKSRC}/qpy/QtGui/Makefile
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt4-gui/pkg-descr b/x11-toolkits/py-qt4-gui/pkg-descr
index 2b9a2d9c3a2..98e1be13524 100644
--- a/x11-toolkits/py-qt4-gui/pkg-descr
+++ b/x11-toolkits/py-qt4-gui/pkg-descr
@@ -1,4 +1,4 @@
-PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.
+PyQt4 is a set of Python bindings for Digia's Qt4 application framework.
This package provides the QtGui module.
WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/x11-toolkits/py-qt4-gui/pkg-plist b/x11-toolkits/py-qt4-gui/pkg-plist
index a08d8036e87..d84e831c8dd 100644
--- a/x11-toolkits/py-qt4-gui/pkg-plist
+++ b/x11-toolkits/py-qt4-gui/pkg-plist
@@ -72,6 +72,7 @@ share/py-sip/QtGui/qgraphicsview.sip
share/py-sip/QtGui/qgraphicswidget.sip
share/py-sip/QtGui/qgridlayout.sip
share/py-sip/QtGui/qgroupbox.sip
+share/py-sip/QtGui/qguiapplication.sip
share/py-sip/QtGui/qheaderview.sip
share/py-sip/QtGui/qicon.sip
share/py-sip/QtGui/qiconengine.sip
@@ -106,6 +107,7 @@ share/py-sip/QtGui/qmessagebox.sip
share/py-sip/QtGui/qmime.sip
share/py-sip/QtGui/qmouseeventtransition.sip
share/py-sip/QtGui/qmovie.sip
+share/py-sip/QtGui/qpagedpaintdevice.sip
share/py-sip/QtGui/qpagesetupdialog.sip
share/py-sip/QtGui/qpaintdevice.sip
share/py-sip/QtGui/qpaintengine.sip
@@ -135,6 +137,7 @@ share/py-sip/QtGui/qrawfont.sip
share/py-sip/QtGui/qregion.sip
share/py-sip/QtGui/qrgb.sip
share/py-sip/QtGui/qrubberband.sip
+share/py-sip/QtGui/qscreen.sip
share/py-sip/QtGui/qscrollarea.sip
share/py-sip/QtGui/qscrollbar.sip
share/py-sip/QtGui/qsessionmanager.sip
@@ -180,6 +183,7 @@ share/py-sip/QtGui/qtoolbar.sip
share/py-sip/QtGui/qtoolbox.sip
share/py-sip/QtGui/qtoolbutton.sip
share/py-sip/QtGui/qtooltip.sip
+share/py-sip/QtGui/qtouchdevice.sip
share/py-sip/QtGui/qtransform.sip
share/py-sip/QtGui/qtreeview.sip
share/py-sip/QtGui/qtreewidget.sip