aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /x11-toolkits
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-fltk/Makefile5
-rw-r--r--x11-toolkits/py-fox/Makefile2
-rw-r--r--x11-toolkits/py-gtkextra/Makefile1
-rw-r--r--x11-toolkits/py-gui/Makefile2
-rw-r--r--x11-toolkits/py-tkinter/Makefile2
-rw-r--r--x11-toolkits/py-tktreectrl/Makefile2
-rw-r--r--x11-toolkits/py-wmdockapps/Makefile1
-rw-r--r--x11-toolkits/py-wxPython24/Makefile1
-rw-r--r--x11-toolkits/py-wxPython24/files/patch-aa16
-rw-r--r--x11-toolkits/py-xlib/Makefile2
10 files changed, 33 insertions, 1 deletions
diff --git a/x11-toolkits/py-fltk/Makefile b/x11-toolkits/py-fltk/Makefile
index 1a0aeab6529..9a95f49b341 100644
--- a/x11-toolkits/py-fltk/Makefile
+++ b/x11-toolkits/py-fltk/Makefile
@@ -19,10 +19,13 @@ COMMENT= Python interface to FLTK window toolkit
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-USE_PYTHON= yes
+USE_PYTHON= -2.4
USE_PYDISTUTILS= yes
USE_XLIB= yes
+PYDISTUTILS_PKGNAME= pyFltk
+PYDISTUTILS_PKGVERSION= 1.1b3
+
MAKE_ENV+= FLTK_HOME=${X11BASE}/include OPENGL_HOME=${X11BASE}/include
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/x11-toolkits/py-fox/Makefile b/x11-toolkits/py-fox/Makefile
index 83e7fb47e07..2c9760bde67 100644
--- a/x11-toolkits/py-fox/Makefile
+++ b/x11-toolkits/py-fox/Makefile
@@ -24,6 +24,8 @@ USE_PYDISTUTILS= yes
USE_XLIB= yes
USE_GL= yes
+PYDISTUTILS_PKGNAME= FXPy
+
WRKSRC= ${WRKDIR}/FXPy-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/x11-toolkits/py-gtkextra/Makefile b/x11-toolkits/py-gtkextra/Makefile
index cca363ce897..ef66bbdcddf 100644
--- a/x11-toolkits/py-gtkextra/Makefile
+++ b/x11-toolkits/py-gtkextra/Makefile
@@ -24,5 +24,6 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-1.2/GTK.py:${PORTSDIR}/x11-toolkits/py-gtk
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-gtkextra
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gui/Makefile b/x11-toolkits/py-gui/Makefile
index 50065ba42e8..4ebf920a096 100644
--- a/x11-toolkits/py-gui/Makefile
+++ b/x11-toolkits/py-gui/Makefile
@@ -21,6 +21,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_GNOME= pygtk2
+PYDISTUTILS_PKGNAME= PyGUI
+
DOCSDIR= share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= share/examples/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index 2016d990a6d..c19c3a2f0db 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -23,6 +23,8 @@ DIST_SUBDIR= python
PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/_tkinter.so
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= Tkinter
+PYDISTUTILS_PKGVERSION= 0.0.0
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
diff --git a/x11-toolkits/py-tktreectrl/Makefile b/x11-toolkits/py-tktreectrl/Makefile
index 176e99fb419..b4574b37b1d 100644
--- a/x11-toolkits/py-tktreectrl/Makefile
+++ b/x11-toolkits/py-tktreectrl/Makefile
@@ -24,5 +24,7 @@ USE_TK_RUN= yes
USE_ZIP= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TkinterTreectrl
+PYDISTUTILS_PKGVERSION= 0.4
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-wmdockapps/Makefile b/x11-toolkits/py-wmdockapps/Makefile
index 5507cf87ffa..ce1141530b1 100644
--- a/x11-toolkits/py-wmdockapps/Makefile
+++ b/x11-toolkits/py-wmdockapps/Makefile
@@ -19,6 +19,7 @@ COMMENT= Tools for making dockapps in Python
USE_XLIB= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pywmdockapps
post-patch:
${REINPLACE_CMD} 's|/usr/X11R6|${X11BASE}|' ${WRKSRC}/setup.py
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index 6b5e99b3849..5da7ca74128 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -26,6 +26,7 @@ USE_GMAKE= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}"
+PYDISTUTILS_NOEGGINFO= yes
USE_WX= 2.4
DEMO_DIR= ${PYTHONPREFIX_SITELIBDIR}/wxPython/demo
diff --git a/x11-toolkits/py-wxPython24/files/patch-aa b/x11-toolkits/py-wxPython24/files/patch-aa
new file mode 100644
index 00000000000..42bd28ded7f
--- /dev/null
+++ b/x11-toolkits/py-wxPython24/files/patch-aa
@@ -0,0 +1,16 @@
+--- wxPython/py/introspect.py.orig Mon Jul 30 08:07:25 2007
++++ wxPython/py/introspect.py Mon Jul 30 08:07:35 2007
+@@ -1,11 +1,11 @@
+ """Provides a variety of introspective-type support functions for
+ things like call tips and command auto completion."""
+
++from __future__ import nested_scopes
++
+ __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
+ __cvsid__ = "$Id: introspect.py,v 1.1.2.2 2003/05/19 21:41:24 PKO Exp $"
+ __revision__ = "$Revision: 1.1.2.2 $"[11:-2]
+-
+-from __future__ import nested_scopes
+
+ import cStringIO
+ import inspect
diff --git a/x11-toolkits/py-xlib/Makefile b/x11-toolkits/py-xlib/Makefile
index 5fa6e3926cb..df565d8db98 100644
--- a/x11-toolkits/py-xlib/Makefile
+++ b/x11-toolkits/py-xlib/Makefile
@@ -18,5 +18,7 @@ COMMENT= X11 library for Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-xlib
+PYDISTUTILS_PKGVERSION= 0.12
.include <bsd.port.mk>