aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /x11-toolkits
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk2/Makefile2
-rw-r--r--x11-toolkits/fxscintilla/Makefile2
-rw-r--r--x11-toolkits/py-sexy/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/x11-toolkits/fltk2/Makefile b/x11-toolkits/fltk2/Makefile
index 37720634cd5..28677715fb3 100644
--- a/x11-toolkits/fltk2/Makefile
+++ b/x11-toolkits/fltk2/Makefile
@@ -81,7 +81,7 @@ CONFIGURE_ARGS+= --enable-cairo
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
# XXX:
# FLTK2's configure check currently depends on pkg-config being available...
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
.else
CONFIGURE_ARGS+= --disable-cairo
.endif
diff --git a/x11-toolkits/fxscintilla/Makefile b/x11-toolkits/fxscintilla/Makefile
index 597bfb05659..dc4a00d7f5f 100644
--- a/x11-toolkits/fxscintilla/Makefile
+++ b/x11-toolkits/fxscintilla/Makefile
@@ -17,13 +17,13 @@ COMMENT= A Fox toolkit reimplementation of Scintilla editing widget
LICENSE= LGPL21 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-sexy/Makefile b/x11-toolkits/py-sexy/Makefile
index 9313b78f645..151e5624e1c 100644
--- a/x11-toolkits/py-sexy/Makefile
+++ b/x11-toolkits/py-sexy/Makefile
@@ -16,12 +16,12 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Libsexy bindings for Python
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= sexy.2:${PORTSDIR}/x11-toolkits/libsexy
USE_AUTOTOOLS= libtool
USE_GNOME= pygtk2
USE_PYTHON= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
.include <bsd.port.mk>