aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-22 17:50:21 +0800
committerbapt <bapt@FreeBSD.org>2014-04-22 17:50:21 +0800
commitca2c77b982e6283cbdb807e017b1a58513eed046 (patch)
tree75879c04e3ed372ffec32748a5688b5b4b03c8a1 /x11-toolkits
parenteafd0c726ef269e0c54ad6da963c2359da570900 (diff)
downloadfreebsd-ports-graphics-ca2c77b982e6283cbdb807e017b1a58513eed046.tar.gz
freebsd-ports-graphics-ca2c77b982e6283cbdb807e017b1a58513eed046.tar.zst
freebsd-ports-graphics-ca2c77b982e6283cbdb807e017b1a58513eed046.zip
Support stage
respect DOCS and EXAMPLES options
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile42
-rw-r--r--x11-toolkits/py-gnome-desktop/pkg-plist70
2 files changed, 52 insertions, 60 deletions
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
index a6892341477..655dad50111 100644
--- a/x11-toolkits/py-gnome-desktop/Makefile
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-desktop
PORTVERSION= 2.32.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -15,49 +15,41 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of Python bindings used by modules in the GNOME Desktop
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_SUB= yes
+
BUILD_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy \
metacity<2.34.0:${PORTSDIR}/x11-wm/metacity
-LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
- totem-plparser.17:${PORTSDIR}/multimedia/totem-pl-parser \
- gnome-media-profiles.0:${PORTSDIR}/audio/gnome-media \
- gnome-keyring:${PORTSDIR}/security/libgnome-keyring \
- brasero-media.3:${PORTSDIR}/sysutils/brasero \
- evdocument.3:${PORTSDIR}/graphics/evince
+LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
+ libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
+ libgnome-media-profiles.so:${PORTSDIR}/audio/gnome-media \
+ libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
+ libbrasero-media.so:${PORTSDIR}/sysutils/brasero \
+ libevdocument.so:${PORTSDIR}/graphics/evince
RUN_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy
-USE_BZIP2= yes
-USES= gmake pkgconfig
+USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_PYTHON= 2
-USE_GNOME= gnomehack libgnomeprintui gnomepanel gnomedesktop \
+USE_GNOME= libgnomeprintui gnomepanel gnomedesktop \
gtksourceview libwnck nautilus2 pygnome2 metacity \
evolutiondataserver
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-metacity --disable-nautilusburn
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
-.if !defined(NOPORTDOCS)
-DOCSDIR= ${PREFIX}/share/doc/py-gnome-desktop
-.else
-DOCSDIR= ${WRKSRC}/share/doc/py-gnome-desktop
-.endif
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
post-patch:
@${FIND} ${WRKSRC}/docs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
-e 's|^HTML_DIR =.*|HTML_DIR = ${DOCSDIR}|g'
@${REINPLACE_CMD} -e 's|2.30|2.32|g' ${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${EG_DST_DIR}
- ${TAR} -C ${EG_SRC_DIR} --exclude *nautilusburn* -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
- ${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
- ${CHMOD} -R go-w ${EG_DST_DIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EG_DST_DIR}
+ cd ${EG_SRC_DIR}; ${COPYTREE_SHARE} . ${STAGEDIR}${EG_DST_DIR}
+ ${RM} -rf ${STAGEDIR}${EG_DST_DIR}/nautilusburn
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gnome-desktop/pkg-plist b/x11-toolkits/py-gnome-desktop/pkg-plist
index 0de7d54e5ac..e3f756ae7e2 100644
--- a/x11-toolkits/py-gnome-desktop/pkg-plist
+++ b/x11-toolkits/py-gnome-desktop/pkg-plist
@@ -84,33 +84,33 @@ libdata/pkgconfig/gnome-python-desktop-2.0.pc
%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/index.html
%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/index.sgml
%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/pygtksourceview.devhelp
-%%PORTDOCS%%share/examples/py-gnome/applet/GNOME_PythonAppletSample.server
-%%PORTDOCS%%share/examples/py-gnome/applet/README
-%%PORTDOCS%%share/examples/py-gnome/applet/applet.py
-%%PORTDOCS%%share/examples/py-gnome/braseroburn/write-audio-video.py
-%%PORTDOCS%%share/examples/py-gnome/braseroburn/write-data.py
-%%PORTDOCS%%share/examples/py-gnome/braseroburn/write-image.py
-%%PORTDOCS%%share/examples/py-gnome/braseromedia/drive_selection.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/README
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_01.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_02.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_03.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_04.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_05.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_06.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_08.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_09.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_10.glade
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_10.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_11.py
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/sample-image.png
-%%PORTDOCS%%share/examples/py-gnome/gnomeprint/test-print.py
-%%PORTDOCS%%share/examples/py-gnome/gtksourceview/test-widget.py
-%%PORTDOCS%%share/examples/py-gnome/keyring-async.py
-%%PORTDOCS%%share/examples/py-gnome/keyring.py
-%%PORTDOCS%%share/examples/py-gnome/mediaprofiles/profiles.py
-%%PORTDOCS%%share/examples/py-gnome/rsvg/rsvg-cairo.py
-%%PORTDOCS%%share/examples/py-gnome/wnck_example.py
+%%EXAMPLES%%share/examples/py-gnome/applet/GNOME_PythonAppletSample.server
+%%EXAMPLES%%share/examples/py-gnome/applet/README
+%%EXAMPLES%%share/examples/py-gnome/applet/applet.py
+%%EXAMPLES%%share/examples/py-gnome/braseroburn/write-audio-video.py
+%%EXAMPLES%%share/examples/py-gnome/braseroburn/write-data.py
+%%EXAMPLES%%share/examples/py-gnome/braseroburn/write-image.py
+%%EXAMPLES%%share/examples/py-gnome/braseromedia/drive_selection.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/README
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_01.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_02.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_03.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_04.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_05.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_06.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_08.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_09.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_10.glade
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_10.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/example_11.py
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/sample-image.png
+%%EXAMPLES%%share/examples/py-gnome/gnomeprint/test-print.py
+%%EXAMPLES%%share/examples/py-gnome/gtksourceview/test-widget.py
+%%EXAMPLES%%share/examples/py-gnome/keyring-async.py
+%%EXAMPLES%%share/examples/py-gnome/keyring.py
+%%EXAMPLES%%share/examples/py-gnome/mediaprofiles/profiles.py
+%%EXAMPLES%%share/examples/py-gnome/rsvg/rsvg-cairo.py
+%%EXAMPLES%%share/examples/py-gnome/wnck_example.py
share/pygtk/2.0/defs/_gnomedesktop.defs
share/pygtk/2.0/defs/applet.defs
share/pygtk/2.0/defs/art.defs
@@ -125,14 +125,14 @@ share/pygtk/2.0/defs/metacity.defs
share/pygtk/2.0/defs/print.defs
share/pygtk/2.0/defs/printui.defs
share/pygtk/2.0/defs/wnck.defs
-%%PORTDOCS%%@dirrm share/examples/py-gnome/rsvg
-%%PORTDOCS%%@dirrm share/examples/py-gnome/mediaprofiles
-%%PORTDOCS%%@dirrm share/examples/py-gnome/gtksourceview
-%%PORTDOCS%%@dirrm share/examples/py-gnome/gnomeprint
-%%PORTDOCS%%@dirrm share/examples/py-gnome/braseromedia
-%%PORTDOCS%%@dirrm share/examples/py-gnome/braseroburn
-%%PORTDOCS%%@dirrm share/examples/py-gnome/applet
-%%PORTDOCS%%@dirrmtry share/examples/py-gnome
+%%EXAMPLES%%@dirrm share/examples/py-gnome/rsvg
+%%EXAMPLES%%@dirrm share/examples/py-gnome/mediaprofiles
+%%EXAMPLES%%@dirrm share/examples/py-gnome/gtksourceview
+%%EXAMPLES%%@dirrm share/examples/py-gnome/gnomeprint
+%%EXAMPLES%%@dirrm share/examples/py-gnome/braseromedia
+%%EXAMPLES%%@dirrm share/examples/py-gnome/braseroburn
+%%EXAMPLES%%@dirrm share/examples/py-gnome/applet
+%%EXAMPLES%%@dirrmtry share/examples/py-gnome
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygtksourceview
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprintui
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprint