aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-17 19:19:54 +0800
committersat <sat@FreeBSD.org>2007-04-17 19:19:54 +0800
commitd0b354d4aea5c3c2d8460568e25217efde8716fa (patch)
treeb4b9676a97d436f58df34d8fe7d8a152db21d4cd /x11-toolkits
parenta996784cec4ba0271f6d1ed06dc5d81bca3f6c4d (diff)
downloadfreebsd-ports-graphics-d0b354d4aea5c3c2d8460568e25217efde8716fa.tar.gz
freebsd-ports-graphics-d0b354d4aea5c3c2d8460568e25217efde8716fa.tar.zst
freebsd-ports-graphics-d0b354d4aea5c3c2d8460568e25217efde8716fa.zip
Add port x11-toolkits/p5-Tk-DKW:
Tk::CheckBox - A radio button style widget that uses a check mark in a box. Useful as a boolean field. Tk::Columns - A multicolumn list widget with resizeable borders and sorting by column. Tk::ComboEntry - A Drop down listbox + entry widget with nice keyboard equivalent behaviour Tk::IconCanvas - A canvas implementing a moveable iconic interface. Allows attaching menus to icons and to background. Tk::SplitFrame - A sliding separator for two child widgets. Allows either horizontal or vertical separation between the two widgets. Can work in concert as horizontal inside vertical or vice-versa. Tk::TabFrame - A tabbed frame geometry manager (like NoteBook). Tk::DockFrame - A dockable widget management widget hierarchy. Tk::CornerBox - A textured window resizing widget (like in Win95) Tk::Signals - A publish and subscribe object signalling method like that found in QT. Very useful when widgets that are not in the same hierarchy need to alert each other to various application level events. WWW: http://search.cpan.org/dist/Tk-DKW/ Author: Damion K. Wilson <dkw@rcm.bm>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Tk-DKW/Makefile31
-rw-r--r--x11-toolkits/p5-Tk-DKW/distinfo3
-rw-r--r--x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL13
-rw-r--r--x11-toolkits/p5-Tk-DKW/pkg-descr22
-rw-r--r--x11-toolkits/p5-Tk-DKW/pkg-plist18
6 files changed, 88 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 56565e80b1d..977ac9c5e5a 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -153,6 +153,7 @@
SUBDIR += p5-Tk-Autoscroll
SUBDIR += p5-Tk-ColourChooser
SUBDIR += p5-Tk-Contrib
+ SUBDIR += p5-Tk-DKW
SUBDIR += p5-Tk-Date
SUBDIR += p5-Tk-DynaTabFrame
SUBDIR += p5-Tk-Enscript
diff --git a/x11-toolkits/p5-Tk-DKW/Makefile b/x11-toolkits/p5-Tk-DKW/Makefile
new file mode 100644
index 00000000000..eea3320787d
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Tk-DKW
+# Date created: 16 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-DKW
+PORTVERSION= 0.03
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Collection of Tk widgets
+
+BUILD_DEPENDS= p5-Tk>=804:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-Tk-Contrib>=0.07:${PORTSDIR}/x11-toolkits/p5-Tk-Contrib
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+DKW_MODULES= CheckBox Columns ComboEntry CornerBox DockFrame IconCanvas\
+ Menustrip ProgressIndicator SplitFrame TabFrame TabbedForm\
+ TableEdit
+MAN3= ${DKW_MODULES:S/^/Tk::/:S/$/.3/}
+
+post-extract:
+ @${MV} ${WRKSRC}/Tk/* ${WRKSRC}/
+ @${RMDIR} ${WRKSRC}/Tk/
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Tk-DKW/distinfo b/x11-toolkits/p5-Tk-DKW/distinfo
new file mode 100644
index 00000000000..264608b8c03
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tk-DKW-0.03.tar.gz) = 01fb09c497cbeff373d743ae7b8388f0
+SHA256 (Tk-DKW-0.03.tar.gz) = 5fede6f2f476ebcbdae868a3a33708d99824980f46c234d0f06cee70e81f22ab
+SIZE (Tk-DKW-0.03.tar.gz) = 50997
diff --git a/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL b/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL
new file mode 100644
index 00000000000..c756cae1b98
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL
@@ -0,0 +1,13 @@
+--- ./Makefile.PL.orig Tue Apr 17 13:19:53 2007
++++ ./Makefile.PL Tue Apr 17 13:20:16 2007
+@@ -23,8 +23,8 @@
+
+ PMLIBDIRS => ['Tk'],
+ DISTNAME => 'Tk-DKW',
+- VERSION => '0.02',
+- NAME => 'Tk',
++ VERSION => '0.03',
++ NAME => 'Tk::DKW',
+
+ 'dist' =>
+ {
diff --git a/x11-toolkits/p5-Tk-DKW/pkg-descr b/x11-toolkits/p5-Tk-DKW/pkg-descr
new file mode 100644
index 00000000000..bac0066e017
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/pkg-descr
@@ -0,0 +1,22 @@
+Tk::CheckBox - A radio button style widget that uses a
+ check mark in a box. Useful as a boolean field.
+Tk::Columns - A multicolumn list widget with resizeable borders
+ and sorting by column.
+Tk::ComboEntry - A Drop down listbox + entry widget with nice keyboard
+ equivalent behaviour
+Tk::IconCanvas - A canvas implementing a moveable iconic interface.
+ Allows attaching menus to icons and to background.
+Tk::SplitFrame - A sliding separator for two child widgets. Allows either
+ horizontal or vertical separation between the two widgets.
+ Can work in concert as horizontal inside vertical or
+ vice-versa.
+Tk::TabFrame - A tabbed frame geometry manager (like NoteBook).
+Tk::DockFrame - A dockable widget management widget hierarchy.
+Tk::CornerBox - A textured window resizing widget (like in Win95)
+Tk::Signals - A publish and subscribe object signalling method like
+ that found in QT. Very useful when widgets that are not
+ in the same hierarchy need to alert each other to various
+ application level events.
+
+WWW: http://search.cpan.org/dist/Tk-DKW/
+Author: Damion K. Wilson <dkw@rcm.bm>
diff --git a/x11-toolkits/p5-Tk-DKW/pkg-plist b/x11-toolkits/p5-Tk-DKW/pkg-plist
new file mode 100644
index 00000000000..5f85d970f27
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/DKW/.packlist
+%%SITE_PERL%%/Tk/CheckBox.pm
+%%SITE_PERL%%/Tk/ChildNotification.pm
+%%SITE_PERL%%/Tk/Columns.pm
+%%SITE_PERL%%/Tk/ComboEntry.pm
+%%SITE_PERL%%/Tk/CornerBox.pm
+%%SITE_PERL%%/Tk/DockFrame.pm
+%%SITE_PERL%%/Tk/IconCanvas.pm
+%%SITE_PERL%%/Tk/Menustrip.pm
+%%SITE_PERL%%/Tk/ProgressIndicator.pm
+%%SITE_PERL%%/Tk/Signals.pm
+%%SITE_PERL%%/Tk/SplitFrame.pm
+%%SITE_PERL%%/Tk/TabFrame.pm
+%%SITE_PERL%%/Tk/TabbedForm.pm
+%%SITE_PERL%%/Tk/TableEdit.pm
+@dirrmtry %%SITE_PERL%%/Tk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/DKW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk