aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /x11-toolkits
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-graphics-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/v/Makefile12
-rw-r--r--x11-toolkits/viewkit/Makefile12
-rw-r--r--x11-toolkits/viewklass/Makefile10
-rw-r--r--x11-toolkits/xview/Makefile12
4 files changed, 23 insertions, 23 deletions
diff --git a/x11-toolkits/v/Makefile b/x11-toolkits/v/Makefile
index 4a60d597bbc..a236c7b575b 100644
--- a/x11-toolkits/v/Makefile
+++ b/x11-toolkits/v/Makefile
@@ -18,18 +18,18 @@ COMMENT= A C++ GUI development framework for X11 and Microsoft Windows
BROKEN= compiler error in function fixup_memory_subreg
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/v
USE_X_PREFIX= YES
USE_GMAKE= YES
MAKE_ENV= INSTALLDIR=${PREFIX} HOMEV=${WRKSRC}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-configure:
${CP} ${WRKSRC}/ConfigX.mk ${WRKSRC}/Config.mk
diff --git a/x11-toolkits/viewkit/Makefile b/x11-toolkits/viewkit/Makefile
index bd8a2307b27..27c5957e4d3 100644
--- a/x11-toolkits/viewkit/Makefile
+++ b/x11-toolkits/viewkit/Makefile
@@ -21,12 +21,6 @@ COMMENT= ViewKit workalike from Hungry Programmers
BUILD_DEPENDS= ${AUTOCONFIG}:${PORTSDIR}/devel/${AUTOCONFIG}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
AUTOCONFIG= autoconf
MOTIFPACKAGE?= open-motif
@@ -35,6 +29,12 @@ USE_MOTIF = yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-${MOTIFPACKAGE}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-configure:
@cd ${WRKSRC}; ${CHMOD} +w configure; ${AUTOCONFIG}
diff --git a/x11-toolkits/viewklass/Makefile b/x11-toolkits/viewklass/Makefile
index 651b3e84474..c5242a278f9 100644
--- a/x11-toolkits/viewklass/Makefile
+++ b/x11-toolkits/viewklass/Makefile
@@ -18,17 +18,17 @@ COMMENT= C++ Framework for Motif
BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake
+USE_X_PREFIX= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_X_PREFIX= yes
-USE_MOTIF= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-
post-patch:
@${REINPLACE_CMD} -e 's/^CFLAGS=/CFLAGS+=/g ; \
s/^CXXFLAGS=/CXXFLAGS+=/g ; \
diff --git a/x11-toolkits/xview/Makefile b/x11-toolkits/xview/Makefile
index 979d971704f..76d3b6e5feb 100644
--- a/x11-toolkits/xview/Makefile
+++ b/x11-toolkits/xview/Makefile
@@ -18,12 +18,6 @@ DISTNAME= xview3.2p1-X11R6
MAINTAINER= ports@FreeBSD.org
COMMENT= X Window-System-based Visual/Integrated Environment for Workstations
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_IMAKE= yes
INSTALLS_SHLIB= yes
IMAKEINCLUDE= "-I${X11BASE}/lib/X11/config -I${WRKSRC}/config"
@@ -33,6 +27,12 @@ ALL_TARGET= World
MAN1= msgfmt.1 xgettext.1 xview.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@(cd $(WRKSRC); $(MAKE) -k 'SUBDIRS=doc' install)