aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-11-06 05:28:51 +0800
committermarcus <marcus@FreeBSD.org>2002-11-06 05:28:51 +0800
commitfcc925a6a402ea0541de8a3426b86af4c818341f (patch)
treefc24fc2c0074d6bd8342d8ce7ff265c57dcdf2f3 /x11-toolkits
parent3debf76b90891095a1effc99a11b74f401f5ea89 (diff)
downloadfreebsd-ports-graphics-fcc925a6a402ea0541de8a3426b86af4c818341f.tar.gz
freebsd-ports-graphics-fcc925a6a402ea0541de8a3426b86af4c818341f.tar.zst
freebsd-ports-graphics-fcc925a6a402ea0541de8a3426b86af4c818341f.zip
Do not enable XInput by default. While it works well with gtk12, there
still seems to be some issues with gtk20. Instead, allow users that really want XInput support to enable it using -DWITH_XINPUT Problem reported by: William N. Culler Jr. <william@neo.rr.com>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile8
-rw-r--r--x11-toolkits/gtk30/Makefile8
2 files changed, 12 insertions, 4 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 5b76495b8d3..0487187b86e 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
@@ -37,8 +38,7 @@ USE_GNOMENG= yes
USE_GNOME= gnomehack
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --enable-static \
- --with-xinput=xfree
+CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -47,6 +47,10 @@ PLIST_SUB= GTK_VERSION="2.0.0"
MAN1= gdk-pixbuf-csource.1
+.if defined(WITH_XINPUT)
+CONFIGURE_ARGS+= --with-xinput=xfree
+.endif
+
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${GREP} -l lgmodule | \
xargs ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 5b76495b8d3..0487187b86e 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
@@ -37,8 +38,7 @@ USE_GNOMENG= yes
USE_GNOME= gnomehack
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --enable-static \
- --with-xinput=xfree
+CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -47,6 +47,10 @@ PLIST_SUB= GTK_VERSION="2.0.0"
MAN1= gdk-pixbuf-csource.1
+.if defined(WITH_XINPUT)
+CONFIGURE_ARGS+= --with-xinput=xfree
+.endif
+
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${GREP} -l lgmodule | \
xargs ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'