aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/afterstep-stable/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-07-23 15:36:32 +0800
committerasami <asami@FreeBSD.org>1996-07-23 15:36:32 +0800
commit363d5999baf44797558bfa7abab4b3a33f746863 (patch)
tree52cbe21b0d35d82a3ecb4f0e22c0fa73dc84ccde /x11-wm/afterstep-stable/Makefile
parent013816138c4ee9870c8ecfc0475a8b7279a770e7 (diff)
downloadfreebsd-ports-graphics-363d5999baf44797558bfa7abab4b3a33f746863.tar.gz
freebsd-ports-graphics-363d5999baf44797558bfa7abab4b3a33f746863.tar.zst
freebsd-ports-graphics-363d5999baf44797558bfa7abab4b3a33f746863.zip
The afterstep window manager, replacing bowman. It's a NeXTstep wm
clone. Submitted by: James FitzGibbon <james@nexis.net>
Diffstat (limited to 'x11-wm/afterstep-stable/Makefile')
-rw-r--r--x11-wm/afterstep-stable/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
new file mode 100644
index 00000000000..f3725e9aa75
--- /dev/null
+++ b/x11-wm/afterstep-stable/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: afterstep
+# Version required: 0.98b16
+# Date created: 17 July 96
+# Whom: james@bdd.net
+#
+# $Id$
+#
+
+DISTNAME= as-b16
+PKGNAME= afterstep-0.98b16
+CATEGORIES+= x11
+MASTER_SITES= ftp://oak.sfasu.edu/pub/AfterStep/
+
+MAINTAINER= james@nexis.net
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+RUN_DEPENDS= fvwm:${PORTSDIR}/x11/fvwm
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}/AfterStep-0.98a16
+
+pre-build:
+ @cd ${WRKSRC}; sh MakeMakefiles
+
+post-install:
+ @mkdir -p ${PREFIX}/include/X11/pixmaps
+ @cp ${WRKSRC}/icons/*.xpm ${PREFIX}/include/X11/pixmaps
+ @cp ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps
+
+.include <bsd.port.mk>