aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/icewm/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-12 02:45:17 +0800
committernork <nork@FreeBSD.org>2003-07-12 02:45:17 +0800
commit0b78f00e6d08d7159b8f9d3e2e76e209b65e15a0 (patch)
treefc46c129d488d8e63d5908bcdf1133e19e801ca8 /x11-wm/icewm/Makefile
parentc082242f905006137876fa29477ff5f14b1cfb04 (diff)
downloadfreebsd-ports-graphics-0b78f00e6d08d7159b8f9d3e2e76e209b65e15a0.tar.gz
freebsd-ports-graphics-0b78f00e6d08d7159b8f9d3e2e76e209b65e15a0.tar.zst
freebsd-ports-graphics-0b78f00e6d08d7159b8f9d3e2e76e209b65e15a0.zip
Update to 1.2.8.
PR: ports/53340 Submitted by: Ports Fury Approved by: maintainer timeout (a long time)
Diffstat (limited to 'x11-wm/icewm/Makefile')
-rw-r--r--x11-wm/icewm/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 92ab54c48d6..8c8b448a1a8 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -6,27 +6,26 @@
#
PORTNAME= icewm
-PORTVERSION= 1.2.7
-PORTREVISION= 1
+PORTVERSION= 1.2.8
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= nakai@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Window Manager designed for speed, usability and consistency
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
WANT_GNOME= yes
+USE_GNOME= gnometarget
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --disable-xfreetype \
- --with-cfgdir=${PREFIX}/share/icewm \
- --with-libdir=${PREFIX}/share/icewm \
+ --with-cfgdir=${DATADIR} \
+ --with-libdir=${DATADIR} \
--with-kdedatadir=${LOCALBASE}/share \
--with-docdir=${PREFIX}/share/doc \
--with-mkfontdir=${NONEXISTENT}
@@ -36,14 +35,14 @@ CONFIGURE_ARGS= --disable-xfreetype \
.if ${HAVE_GNOME:Mgnomelibs}!=""
.undef HAVE_ESOUND
USE_GNOME+= gnomelibs
-CONFIGURE_ARGS+= --with-imlib --without-xpm --with-gnome-menus \
+CONFIGURE_ARGS+= --with-imlib --without-xpm --enable-menus-gnome1 \
--enable-guievents --with-icesound=esound
INSTALL_TARGET= install install-gnome
PLIST_SUB+= ESOUND=""
PKGNAMESUFFIX= -gnome
.else
USE_XPM= yes
-CONFIGURE_ARGS+= --without-imlib --with-xpm --without-gnome-menus
+CONFIGURE_ARGS+= --without-imlib --with-xpm
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound
CONFIGURE_ARGS+= --enable-guievents --with-icesound=esound