aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/plank
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-10-12 02:23:43 +0800
committerolivierd <olivierd@FreeBSD.org>2015-10-12 02:23:43 +0800
commit40f2b8fe140bdb553d3112687e28dddf20eb0d42 (patch)
tree8f240317d13a2636de0e4a40215ac4ed3c3819ca /x11-wm/plank
parent1b07dfac512433b5fd1f7d74f730f4ff87978cb4 (diff)
downloadfreebsd-ports-graphics-40f2b8fe140bdb553d3112687e28dddf20eb0d42.tar.gz
freebsd-ports-graphics-40f2b8fe140bdb553d3112687e28dddf20eb0d42.tar.zst
freebsd-ports-graphics-40f2b8fe140bdb553d3112687e28dddf20eb0d42.zip
- Update to 0.10.1
- Fix missing icons with Adwaita icons theme Changelog: http://bazaar.launchpad.net/~docky-core/plank/trunk/view/head:/NEWS#L5
Diffstat (limited to 'x11-wm/plank')
-rw-r--r--x11-wm/plank/Makefile4
-rw-r--r--x11-wm/plank/distinfo4
-rw-r--r--x11-wm/plank/files/patch-lib_Items_PlankDockItem.vala16
3 files changed, 20 insertions, 4 deletions
diff --git a/x11-wm/plank/Makefile b/x11-wm/plank/Makefile
index 511023f446a..93e59c50059 100644
--- a/x11-wm/plank/Makefile
+++ b/x11-wm/plank/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= plank
-PORTVERSION= 0.10.0
+PORTVERSION= 0.10.1
CATEGORIES= x11-wm
-MASTER_SITES= https://launchpadlibrarian.net/216557335/ \
+MASTER_SITES= https://launchpadlibrarian.net/220768016/ \
https://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
MAINTAINER= olivierd@FreeBSD.org
diff --git a/x11-wm/plank/distinfo b/x11-wm/plank/distinfo
index c0c7e27200a..3243f60222d 100644
--- a/x11-wm/plank/distinfo
+++ b/x11-wm/plank/distinfo
@@ -1,2 +1,2 @@
-SHA256 (plank-0.10.0.tar.xz) = 4023eaa59cca3ee35032c23c2b011e1cabac812b8828af9ca55e6aaa084ad203
-SIZE (plank-0.10.0.tar.xz) = 950952
+SHA256 (plank-0.10.1.tar.xz) = 04cf4205fb7fce035bf537395fbfc3cf79aea9692fb4186345fe6a06ce2ebf36
+SIZE (plank-0.10.1.tar.xz) = 951840
diff --git a/x11-wm/plank/files/patch-lib_Items_PlankDockItem.vala b/x11-wm/plank/files/patch-lib_Items_PlankDockItem.vala
new file mode 100644
index 00000000000..941529719ff
--- /dev/null
+++ b/x11-wm/plank/files/patch-lib_Items_PlankDockItem.vala
@@ -0,0 +1,16 @@
+--- lib/Items/PlankDockItem.vala.orig 2015-10-07 12:34:54 UTC
++++ lib/Items/PlankDockItem.vala
+@@ -74,11 +74,11 @@ namespace Plank.Items
+ {
+ var items = new Gee.ArrayList<Gtk.MenuItem> ();
+
+- var item = create_menu_item (_("Get _Help Online..."), "help");
++ var item = create_menu_item (_("Get _Help Online..."), "help-browser");
+ item.activate.connect (() => Application.get_default ().activate_action ("help", null));
+ items.add (item);
+
+- item = create_menu_item (_("_Translate This Application..."), "locale");
++ item = create_menu_item (_("_Translate This Application..."), "preferences-desktop-locale");
+ item.activate.connect (() => Application.get_default ().activate_action ("translate", null));
+ items.add (item);
+