aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-03-30 17:07:53 +0800
committerwill <will@FreeBSD.org>2002-03-30 17:07:53 +0800
commit209d2a899ce9bf74538097c50bbcc27f34bb5cdf (patch)
treef98e5961b4e6021db2109def4ab60c3202fdb0f9 /x11-wm
parent3bf7e2d3241dee10b2271a4f5f73a3503b610e97 (diff)
downloadfreebsd-ports-graphics-209d2a899ce9bf74538097c50bbcc27f34bb5cdf.tar.gz
freebsd-ports-graphics-209d2a899ce9bf74538097c50bbcc27f34bb5cdf.tar.zst
freebsd-ports-graphics-209d2a899ce9bf74538097c50bbcc27f34bb5cdf.zip
Fix the KDE ports to not use objprelink, if OSVERSION >= 500029. This is
not tested other than for syntax, but should DTRT from what I understand of the problem. Submitted by: bento
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/kdeartwork/Makefile8
-rw-r--r--x11-wm/kdeartwork3/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/x11-wm/kdeartwork/Makefile b/x11-wm/kdeartwork/Makefile
index e7e9a4803a7..4e672bc89ea 100644
--- a/x11-wm/kdeartwork/Makefile
+++ b/x11-wm/kdeartwork/Makefile
@@ -23,6 +23,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -36,4 +42,4 @@ pre-configure:
cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/kdeartwork3/Makefile b/x11-wm/kdeartwork3/Makefile
index e7e9a4803a7..4e672bc89ea 100644
--- a/x11-wm/kdeartwork3/Makefile
+++ b/x11-wm/kdeartwork3/Makefile
@@ -23,6 +23,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -36,4 +42,4 @@ pre-configure:
cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>