aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
committerkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
commit3d272740920a1868e8acfed76d6e4c67c331e101 (patch)
tree2a5c0b3f83feeff6b7818d6af84084a526182651 /x11-wm
parent16773b885888858d80db86065d33dcf723459cbd (diff)
downloadfreebsd-ports-graphics-3d272740920a1868e8acfed76d6e4c67c331e101.tar.gz
freebsd-ports-graphics-3d272740920a1868e8acfed76d6e4c67c331e101.tar.zst
freebsd-ports-graphics-3d272740920a1868e8acfed76d6e4c67c331e101.zip
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Makefile2
-rw-r--r--x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c54
-rw-r--r--x11-wm/emerald/Makefile2
-rw-r--r--x11-wm/emerald/files/patch-src_main.c58
-rw-r--r--x11-wm/metacity/Makefile5
-rw-r--r--x11-wm/metacity/distinfo6
-rw-r--r--x11-wm/metacity/pkg-plist4
-rw-r--r--x11-wm/mutter/Makefile4
-rw-r--r--x11-wm/mutter/distinfo6
-rw-r--r--x11-wm/mutter/pkg-plist4
10 files changed, 128 insertions, 17 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index fe81043df63..3bca40e76b7 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compiz
PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
diff --git a/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c b/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c
index 53b82dae397..1c853c4e2d9 100644
--- a/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c
+++ b/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c
@@ -1,5 +1,14 @@
---- gtk/window-decorator/gtk-window-decorator.c.orig 2010-04-06 18:29:25.000000000 +0200
-+++ gtk/window-decorator/gtk-window-decorator.c 2010-04-06 18:40:04.000000000 +0200
+--- gtk/window-decorator/gtk-window-decorator.c.orig 2009-08-15 09:24:40.000000000 +0200
++++ gtk/window-decorator/gtk-window-decorator.c 2010-10-29 12:56:37.000000000 +0200
+@@ -2671,7 +2671,7 @@ get_window_prop (Window xwindow,
+ gdk_error_trap_push ();
+
+ type = None;
+- result = XGetWindowProperty (gdk_display,
++ result = XGetWindowProperty (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ xwindow,
+ atom,
+ 0, G_MAXLONG,
@@ -4233,7 +4233,7 @@ show_tooltip (const char *text)
static void
hide_tooltip (void)
@@ -9,3 +18,44 @@
g_get_current_time (&tooltip_last_popdown);
gtk_widget_hide (tip_window);
+@@ -4966,7 +4966,7 @@ force_quit_dialog_realize (GtkWidget *di
+ WnckWindow *win = data;
+
+ gdk_error_trap_push ();
+- XSetTransientForHint (gdk_display,
++ XSetTransientForHint (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ GDK_WINDOW_XID (dialog->window),
+ wnck_window_get_xid (win));
+ gdk_display_sync (gdk_display_get_default ());
+@@ -4982,11 +4982,11 @@ get_client_machine (Window xwindow)
+ int format, result;
+ char *retval;
+
+- atom = XInternAtom (gdk_display, "WM_CLIENT_MACHINE", FALSE);
++ atom = XInternAtom (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), "WM_CLIENT_MACHINE", FALSE);
+
+ gdk_error_trap_push ();
+
+- result = XGetWindowProperty (gdk_display,
++ result = XGetWindowProperty (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ xwindow, atom,
+ 0, G_MAXLONG,
+ FALSE, XA_STRING, &type, &format, &nitems,
+@@ -5038,7 +5038,7 @@ kill_window (WnckWindow *win)
+ }
+
+ gdk_error_trap_push ();
+- XKillClient (gdk_display, wnck_window_get_xid (win));
++ XKillClient (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), wnck_window_get_xid (win));
+ gdk_display_sync (gdk_display_get_default ());
+ gdk_error_trap_pop ();
+ }
+@@ -5623,7 +5623,7 @@ static int
+ update_shadow (void)
+ {
+ decor_shadow_options_t opt;
+- Display *xdisplay = gdk_display;
++ Display *xdisplay = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
+ GdkDisplay *display = gdk_display_get_default ();
+ GdkScreen *screen = gdk_display_get_default_screen (display);
+
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index 99462ae264e..d2a3a35156c 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emerald
PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
diff --git a/x11-wm/emerald/files/patch-src_main.c b/x11-wm/emerald/files/patch-src_main.c
new file mode 100644
index 00000000000..adff2eccea3
--- /dev/null
+++ b/x11-wm/emerald/files/patch-src_main.c
@@ -0,0 +1,58 @@
+--- src/main.c.orig 2010-11-02 16:54:19.000000000 +0100
++++ src/main.c 2010-11-02 16:56:04.000000000 +0100
+@@ -2457,7 +2457,7 @@
+ gdk_error_trap_push();
+
+ type = None;
+- result = XGetWindowProperty(gdk_display,
++ result = XGetWindowProperty(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ xwindow,
+ atom,
+ 0, G_MAXLONG,
+@@ -4246,10 +4246,10 @@
+ WnckWindow *win = data;
+
+ gdk_error_trap_push();
+- XSetTransientForHint(gdk_display,
++ XSetTransientForHint(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ GDK_WINDOW_XID(dialog->window),
+ wnck_window_get_xid(win));
+- XSync(gdk_display, FALSE);
++ XSync(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), FALSE);
+ gdk_error_trap_pop();
+ }
+
+@@ -4262,11 +4262,11 @@
+ int format, result;
+ char *retval;
+
+- atom = XInternAtom(gdk_display, "WM_CLIENT_MACHINE", FALSE);
++ atom = XInternAtom(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), "WM_CLIENT_MACHINE", FALSE);
+
+ gdk_error_trap_push();
+
+- result = XGetWindowProperty(gdk_display,
++ result = XGetWindowProperty(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
+ xwindow, atom,
+ 0, G_MAXLONG,
+ FALSE, XA_STRING, &type, &format, &nitems,
+@@ -4318,8 +4318,8 @@
+ }
+
+ gdk_error_trap_push();
+- XKillClient(gdk_display, wnck_window_get_xid(win));
+- XSync(gdk_display, FALSE);
++ XKillClient(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), wnck_window_get_xid(win));
++ XSync(GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), FALSE);
+ gdk_error_trap_pop();
+ }
+
+@@ -4739,7 +4739,7 @@
+
+ static int update_shadow(frame_settings * fs)
+ {
+- Display *xdisplay = gdk_display;
++ Display *xdisplay = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
+ XRenderPictFormat *format;
+ GdkPixmap *pixmap;
+ Picture src, dst, tmp;
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 4b3f3883ecd..4af139d5d19 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -3,12 +3,11 @@
# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/metacity/Makefile,v 1.155 2010/04/06 22:47:54 marcus Exp $
+# $MCom: ports/x11-wm/metacity/Makefile,v 1.158 2010/09/30 07:04:02 kwm Exp $
#
PORTNAME= metacity
-PORTVERSION= 2.30.1
-PORTREVISION= 3
+PORTVERSION= 2.30.3
CATEGORIES= x11-wm
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
index 1883d005560..849e225ec1d 100644
--- a/x11-wm/metacity/distinfo
+++ b/x11-wm/metacity/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/metacity-2.30.1.tar.bz2) = 3d3c05c60b70b9d06b30872e756c31ba
-SHA256 (gnome2/metacity-2.30.1.tar.bz2) = 0057b6e0562cf51b648a2d7b3729def8365ccefd12a9b1373f93312da1ebe5d8
-SIZE (gnome2/metacity-2.30.1.tar.bz2) = 2314657
+MD5 (gnome2/metacity-2.30.3.tar.bz2) = 553784f376d96b902e19ff437cd5b339
+SHA256 (gnome2/metacity-2.30.3.tar.bz2) = 08f887018fa5e447cf184d03bae3fe2c05fdb7583bed6768e3b4d66392fc18dd
+SIZE (gnome2/metacity-2.30.3.tar.bz2) = 2358537
diff --git a/x11-wm/metacity/pkg-plist b/x11-wm/metacity/pkg-plist
index cb1d97b3be3..9c9b5015e07 100644
--- a/x11-wm/metacity/pkg-plist
+++ b/x11-wm/metacity/pkg-plist
@@ -43,6 +43,7 @@ share/locale/el/LC_MESSAGES/metacity.mo
share/locale/en@shaw/LC_MESSAGES/metacity.mo
share/locale/en_CA/LC_MESSAGES/metacity.mo
share/locale/en_GB/LC_MESSAGES/metacity.mo
+share/locale/eo/LC_MESSAGES/metacity.mo
share/locale/es/LC_MESSAGES/metacity.mo
share/locale/et/LC_MESSAGES/metacity.mo
share/locale/eu/LC_MESSAGES/metacity.mo
@@ -78,6 +79,7 @@ share/locale/mn/LC_MESSAGES/metacity.mo
share/locale/mr/LC_MESSAGES/metacity.mo
share/locale/ms/LC_MESSAGES/metacity.mo
share/locale/nb/LC_MESSAGES/metacity.mo
+share/locale/nds/LC_MESSAGES/metacity.mo
share/locale/ne/LC_MESSAGES/metacity.mo
share/locale/nl/LC_MESSAGES/metacity.mo
share/locale/nn/LC_MESSAGES/metacity.mo
@@ -250,6 +252,8 @@ share/themes/Simple/metacity-1/minimize.png
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
diff --git a/x11-wm/mutter/Makefile b/x11-wm/mutter/Makefile
index 7e70ce4e9f5..13ba0648561 100644
--- a/x11-wm/mutter/Makefile
+++ b/x11-wm/mutter/Makefile
@@ -3,11 +3,11 @@
# Whom: Pawel Worach <pawel.worach@gmail.com>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/mutter/Makefile,v 1.11 2010/03/28 15:56:20 kwm Exp $
+# $MCom: ports/x11-wm/mutter/Makefile,v 1.14 2010/06/29 21:14:07 kwm Exp $
#
PORTNAME= mutter
-PORTVERSION= 2.29.1
+PORTVERSION= 2.31.2
PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= GNOME
diff --git a/x11-wm/mutter/distinfo b/x11-wm/mutter/distinfo
index 33ebc570861..59abe4bfe43 100644
--- a/x11-wm/mutter/distinfo
+++ b/x11-wm/mutter/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/mutter-2.29.1.tar.bz2) = ebe3c04751741fb2a028a3c6c4f1c2d7
-SHA256 (gnome2/mutter-2.29.1.tar.bz2) = 175f3adcc5ad5c6f23772ca15c862f275fc3d9a9c3104e9146cf265847a4a10a
-SIZE (gnome2/mutter-2.29.1.tar.bz2) = 1981019
+MD5 (gnome2/mutter-2.31.2.tar.bz2) = c2ca30b2f5af0e53d512062ba081806c
+SHA256 (gnome2/mutter-2.31.2.tar.bz2) = 7267018c2eb28213748810de7e1ccf6d4f059e8ab593ec335234588d0037578c
+SIZE (gnome2/mutter-2.31.2.tar.bz2) = 1983139
diff --git a/x11-wm/mutter/pkg-plist b/x11-wm/mutter/pkg-plist
index a768bbbe388..417dc282f33 100644
--- a/x11-wm/mutter/pkg-plist
+++ b/x11-wm/mutter/pkg-plist
@@ -28,8 +28,8 @@ lib/libmutter-private.a
lib/libmutter-private.la
lib/libmutter-private.so
lib/libmutter-private.so.0
-lib/mutter/Meta-2.29.gir
-lib/mutter/Meta-2.29.typelib
+lib/mutter/Meta-2.31.gir
+lib/mutter/Meta-2.31.typelib
lib/mutter/plugins/default.so
libdata/pkgconfig/libmutter-private.pc
libdata/pkgconfig/mutter-plugins.pc