aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /x11-wm
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-graphics-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-graphics-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-graphics-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/badwm/Makefile2
-rw-r--r--x11-wm/bbconf/Makefile2
-rw-r--r--x11-wm/blwm/Makefile3
-rw-r--r--x11-wm/enlightenment-devel/Makefile2
-rw-r--r--x11-wm/epiwm/Makefile3
-rw-r--r--x11-wm/epplets/Makefile2
-rw-r--r--x11-wm/expocity/Makefile2
-rw-r--r--x11-wm/fluxbox-devel/Makefile2
-rw-r--r--x11-wm/fluxbox/Makefile3
-rw-r--r--x11-wm/ion-2/Makefile3
-rw-r--r--x11-wm/ion3/Makefile3
-rw-r--r--x11-wm/kahakai/Makefile2
-rw-r--r--x11-wm/libdockapp/Makefile2
-rw-r--r--x11-wm/libepplet/Makefile2
-rw-r--r--x11-wm/windowmaker/Makefile2
-rw-r--r--x11-wm/wmg/Makefile2
-rw-r--r--x11-wm/xfce4-desktop/Makefile2
-rw-r--r--x11-wm/xfce4-panel/Makefile2
-rw-r--r--x11-wm/xfce4-session/Makefile2
-rw-r--r--x11-wm/xfce4-systray/Makefile2
-rw-r--r--x11-wm/xfce4-wm/Makefile2
21 files changed, 21 insertions, 26 deletions
diff --git a/x11-wm/badwm/Makefile b/x11-wm/badwm/Makefile
index 603c8a5dc5b..36c29ab3bf2 100644
--- a/x11-wm/badwm/Makefile
+++ b/x11-wm/badwm/Makefile
@@ -19,7 +19,7 @@ COMMENT= Window manager based on evilwm
DOCDIR= share/doc/${PORTNAME}
DOCS= AUTHORS COPYING ChangeLog INSTALL LICENSE README THANKS TODO
PLIST= ${WRKDIR}/pkg-plist
-USE_AUTOCONF_VER= 253
+USE_AUTOTOOLS= autoconf:253
USE_GMAKE= y
USE_X_PREFIX= y
diff --git a/x11-wm/bbconf/Makefile b/x11-wm/bbconf/Makefile
index be7563f5975..483c4d3302a 100644
--- a/x11-wm/bbconf/Makefile
+++ b/x11-wm/bbconf/Makefile
@@ -17,7 +17,7 @@ COMMENT= Configurator for the Blackbox window manager
USE_X_PREFIX= yes
USE_QT_VER= 3
USE_PERL5_BUILD= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bbconf.1
diff --git a/x11-wm/blwm/Makefile b/x11-wm/blwm/Makefile
index d9527032b92..5e5bc420619 100644
--- a/x11-wm/blwm/Makefile
+++ b/x11-wm/blwm/Makefile
@@ -17,8 +17,7 @@ COMMENT= Portuguese derivative of qvwm, simplified to conserve resources
RUN_DEPENDS= xsetbg:${PORTSDIR}/x11/xloadimage
-USE_AUTOCONF_VER= 213
-USE_AUTOMAKE_VER= 14
+USE_AUTOTOOLS= automake:14 autoconf:213
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
MAN1= blwm.1x
diff --git a/x11-wm/enlightenment-devel/Makefile b/x11-wm/enlightenment-devel/Makefile
index 0b9d94e4162..06903f53c93 100644
--- a/x11-wm/enlightenment-devel/Makefile
+++ b/x11-wm/enlightenment-devel/Makefile
@@ -28,7 +28,7 @@ USE_GNOME= gnomehack gnometarget
USE_ICONV= yes
USE_GETTEXT= yes
NO_LATEST_LINK= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/x11-wm/epiwm/Makefile b/x11-wm/epiwm/Makefile
index a4049116a66..a6349d34196 100644
--- a/x11-wm/epiwm/Makefile
+++ b/x11-wm/epiwm/Makefile
@@ -24,8 +24,7 @@ CONFIG= icons key menu start style window workspace
DOCS= AUTHORS BUGS COPYING ChangeLog EPIwm-0.5.6.lsm INSTALL NEWS \
README TODO
PLIST= ${WRKDIR}/pkg-plist
-USE_AUTOCONF_VER= 213
-WANT_AUTOMAKE_VER= 14
+USE_AUTOTOOLS= automake:14:env autoconf:213
USE_X_PREFIX= yes
post-extract:
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index d69f6a5b72a..7cfb498297e 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= esound lthack
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/x11-wm/expocity/Makefile b/x11-wm/expocity/Makefile
index d24eda4fcf4..70f6d6a53b6 100644
--- a/x11-wm/expocity/Makefile
+++ b/x11-wm/expocity/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= metacity*
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_GNOME= gnomeprefix gnomehack gnomehier gconf2 libglade2
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/x11-wm/fluxbox-devel/Makefile b/x11-wm/fluxbox-devel/Makefile
index 93de1533d9f..bdf254a268c 100644
--- a/x11-wm/fluxbox-devel/Makefile
+++ b/x11-wm/fluxbox-devel/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= gnometarget
WANT_GNOME= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
MAN1= fbrun.1 fbsetbg.1 fbsetroot.1 fluxbox.1 fluxstyle.1 \
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index d0475d17492..256a99129fe 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -37,8 +37,7 @@ CONFIGURE_ARGS+= --enable-kde
#.if defined(WITH_REMEMBER)
#USE_GMAKE= yes
-#WANT_AUTOMAKE_VER= 14
-#CONFIGURE_ENV= AUTOMAKE=automake14
+#USE_AUTOTOOLS= automake:14:env
#.endif
.if defined(WITH_XINERAMA) || defined(PACKAGE_BUILDING)
diff --git a/x11-wm/ion-2/Makefile b/x11-wm/ion-2/Makefile
index abcd49d0cd7..53c711dff5f 100644
--- a/x11-wm/ion-2/Makefile
+++ b/x11-wm/ion-2/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
CONFLICTS= ion-2002* ion-devel-* pwm-*
-USE_LIBLTDL= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libltdl:15 libtool:15
USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV= DEFINES="${IONDEFINES}"
diff --git a/x11-wm/ion3/Makefile b/x11-wm/ion3/Makefile
index abcd49d0cd7..53c711dff5f 100644
--- a/x11-wm/ion3/Makefile
+++ b/x11-wm/ion3/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
CONFLICTS= ion-2002* ion-devel-* pwm-*
-USE_LIBLTDL= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libltdl:15 libtool:15
USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV= DEFINES="${IONDEFINES}"
diff --git a/x11-wm/kahakai/Makefile b/x11-wm/kahakai/Makefile
index 7f295b928cb..e3081306412 100644
--- a/x11-wm/kahakai/Makefile
+++ b/x11-wm/kahakai/Makefile
@@ -26,7 +26,7 @@ DEPRECATED= "Development ceased"
USE_BZIP2= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_PYTHON= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
diff --git a/x11-wm/libdockapp/Makefile b/x11-wm/libdockapp/Makefile
index b3419b3bc43..61b2700241b 100644
--- a/x11-wm/libdockapp/Makefile
+++ b/x11-wm/libdockapp/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-font --without-examples
INSTALLS_SHLIB= yes
diff --git a/x11-wm/libepplet/Makefile b/x11-wm/libepplet/Makefile
index 3fba6f25d2d..0daef64f5d6 100644
--- a/x11-wm/libepplet/Makefile
+++ b/x11-wm/libepplet/Makefile
@@ -20,7 +20,7 @@ USE_X_PREFIX= yes
USE_GNOME= imlib
USE_GL= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="${CPPFLAGS}" \
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index fa6df89923b..9ed07c3b73f 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -28,7 +28,7 @@ USE_XPM= yes
USE_PERL5= yes
USE_GETTEXT= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
diff --git a/x11-wm/wmg/Makefile b/x11-wm/wmg/Makefile
index 9c33678348f..27c9eda7904 100644
--- a/x11-wm/wmg/Makefile
+++ b/x11-wm/wmg/Makefile
@@ -19,7 +19,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 917cf5e2bf1..7845d111a25 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -30,7 +30,7 @@ RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index 747c94b283c..ffce0827816 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -28,7 +28,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20 gnomehack
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index ed557b0da5d..0c800b97a7e 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -30,7 +30,7 @@ USE_GNOME= gnomehack
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
diff --git a/x11-wm/xfce4-systray/Makefile b/x11-wm/xfce4-systray/Makefile
index 6f46799bb01..47af341ae67 100644
--- a/x11-wm/xfce4-systray/Makefile
+++ b/x11-wm/xfce4-systray/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index 3c8b7cffa2e..35a0499fd34 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -29,7 +29,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
USE_XPM= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-xinerama