aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-07-08 18:27:20 +0800
committerdanfe <danfe@FreeBSD.org>2011-07-08 18:27:20 +0800
commitc3611c58d5289ed5628de6a181047415d287458e (patch)
treedf395ef51adc0a806b0de13ccab9d01d55b1ae1a /x11-wm
parent574013401c51b57bd442883466bd588b44c7a935 (diff)
downloadfreebsd-ports-graphics-c3611c58d5289ed5628de6a181047415d287458e.tar.gz
freebsd-ports-graphics-c3611c58d5289ed5628de6a181047415d287458e.tar.zst
freebsd-ports-graphics-c3611c58d5289ed5628de6a181047415d287458e.zip
Remove `x11-wm/boxtools' port and provide an OPTION to install tools only.
Blackbox port is very light, and this separation does not really buys us anything expect having to maintain two ports that operate on the very same distfile. I could have probably just completely removed tools-only mode, but there might be folks out there who believe this is a useful feature. Approved by: maintainer (general idea)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/blackbox/Makefile32
-rw-r--r--x11-wm/boxtools/Makefile46
-rw-r--r--x11-wm/boxtools/distinfo2
-rw-r--r--x11-wm/boxtools/pkg-descr4
5 files changed, 22 insertions, 63 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 9fd1270a7cc..888f02d132f 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -19,7 +19,6 @@
SUBDIR += bbpager
SUBDIR += blackbox
SUBDIR += blwm
- SUBDIR += boxtools
SUBDIR += ccsm
SUBDIR += clementine
SUBDIR += compiz
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 77c9644c019..f0c5d08c201 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blackbox
PORTVERSION= 0.70.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}wm/${PORTNAME}wm/Blackbox%20${PORTVERSION}
@@ -16,22 +16,34 @@ COMMENT= A small and fast window manager for X11R6
LICENSE= MIT
-CONFLICTS= boxtools-*
-
-PORTDOCS= AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO
-MAN1= blackbox.1
-
GNU_CONFIGURE= yes
USE_ICONV= yes
USE_GNOME= gnomehack pkgconfig
USE_XORG= x11 xft
-post-patch:
- @${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' \
- ${WRKSRC}/doc/Makefile.in
+MAN1= bsetbg.1 bsetroot.1
+PORTDOCS= README.bbtools README.bsetbg
+
+OPTIONS= TOOLS_ONLY "Do not install window manager, only tools" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TOOLS_ONLY)
+PKGNAMESUFFIX= -tools
+COMMENT+= (tools only)
+MAKE_ARGS= SUBDIRS="doc lib util" bin_PROGRAMS=bsetroot
+INSTALL_TARGET= -C util install # XXX dirty hack :(
+.else
+MAN1+= blackbox.1
+PORTDOCS+= AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO
+.endif
post-install:
+.if defined(WITH_TOOLS_ONLY)
+ @${REINPLACE_CMD} -E '/[^s]\/blackbox|bstyleconvert|lib|include/d' \
+ ${TMPPLIST}
+ ${INSTALL_MAN} ${MAN1:S#^#${WRKSRC}/doc/#} ${MANPREFIX}/man/man1
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S#^#${WRKSRC}/#} ${DOCSDIR}
diff --git a/x11-wm/boxtools/Makefile b/x11-wm/boxtools/Makefile
deleted file mode 100644
index e2a28d1cec5..00000000000
--- a/x11-wm/boxtools/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: boxtools
-# Date created: September 11, 2002
-# Whom: Stijn Hoop <stijn@win.tue.nl>
-#
-# $FreeBSD$
-#
-
-PORTNAME= boxtools
-PORTVERSION= 0.70.1
-PORTREVISION= 2
-CATEGORIES= x11-wm
-MASTER_SITES= SF/blackboxwm/blackboxwm/Blackbox%20${PORTVERSION}
-DISTNAME= blackbox-${PORTVERSION}
-
-MAINTAINER= A.J.Caines@halplant.com
-COMMENT= Style tools for the blackbox family of window managers
-
-CONFLICTS= blackbox-0.[7-9]*
-
-MAN1= bsetbg.1 bsetroot.1
-PORTDOCS= README.bbtools README.bsetbg
-PLIST_FILES= bin/bsetbg bin/bsetroot
-
-USE_XORG= x11 xext
-GNU_CONFIGURE= yes
-USE_ICONV= yes
-
-pre-patch:
- @${REINPLACE_CMD} -e 's#PACKAGE=blackbox#PACKAGE=boxtools#' \
- -e 's#-pedantic##' ${WRKSRC}/configure
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/util/bsetbg ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/util/bsetroot ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/bsetbg.1 ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/bsetroot.1 ${PREFIX}/man/man1
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/x11-wm/boxtools/distinfo b/x11-wm/boxtools/distinfo
deleted file mode 100644
index e1bf361af52..00000000000
--- a/x11-wm/boxtools/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (blackbox-0.70.1.tar.gz) = e394561d4426cf17e21eb5cc32e2972eb1af92d04a41808a41b1fb95320bd659
-SIZE (blackbox-0.70.1.tar.gz) = 650400
diff --git a/x11-wm/boxtools/pkg-descr b/x11-wm/boxtools/pkg-descr
deleted file mode 100644
index 118a2b0381b..00000000000
--- a/x11-wm/boxtools/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Root window changing tools, bsetroot and bsetbg, from the Blackbox window
-manager, for use with other window managers.
-
-WWW: http://blackboxwm.sourceforge.net/BlackboxDocumentation/BlackboxBackground#RootWindowTools