aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-05-19 02:03:47 +0800
committervs <vs@FreeBSD.org>2005-05-19 02:03:47 +0800
commite9fb51fd62768c5bf402f40f410a3616e6d42fd7 (patch)
treeea5df5ad65e05d2141045b6b5bcbf0b07483937d /x11-wm
parentbb4c1359ef8ba621dd18bc3a17c0b8d411feea79 (diff)
downloadfreebsd-ports-graphics-e9fb51fd62768c5bf402f40f410a3616e6d42fd7.tar.gz
freebsd-ports-graphics-e9fb51fd62768c5bf402f40f410a3616e6d42fd7.tar.zst
freebsd-ports-graphics-e9fb51fd62768c5bf402f40f410a3616e6d42fd7.zip
Use MAKE_ARGS & libtool 15
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/epplets/Makefile3
-rw-r--r--x11-wm/epplets/files/patch-Makefile.in11
-rw-r--r--x11-wm/libepplet/Makefile3
-rw-r--r--x11-wm/libepplet/files/patch-Makefile.in11
-rw-r--r--x11-wm/libepplet/files/patch-configure10
5 files changed, 4 insertions, 34 deletions
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index 6ac3f7f49e7..d69f6a5b72a 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -26,12 +26,13 @@ USE_GNOME= esound lthack
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-fsstd
+MAKE_ARGS= SUBDIRS="epplets debian"
.include <bsd.port.pre.mk>
diff --git a/x11-wm/epplets/files/patch-Makefile.in b/x11-wm/epplets/files/patch-Makefile.in
deleted file mode 100644
index 7c496c07f61..00000000000
--- a/x11-wm/epplets/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu Nov 6 07:09:39 2003
-+++ Makefile.in Mon Dec 8 02:20:28 2003
-@@ -107,7 +107,7 @@
-
- AUTOMAKE_OPTIONS = foreign
-
--SUBDIRS = api epplets debian
-+SUBDIRS = epplets debian
-
- EXTRA_DIST = autogen.sh epplets.spec
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/x11-wm/libepplet/Makefile b/x11-wm/libepplet/Makefile
index 5e42686a469..3fba6f25d2d 100644
--- a/x11-wm/libepplet/Makefile
+++ b/x11-wm/libepplet/Makefile
@@ -20,11 +20,12 @@ USE_X_PREFIX= yes
USE_GNOME= imlib
USE_GL= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= SUBDIRS="api debian"
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
diff --git a/x11-wm/libepplet/files/patch-Makefile.in b/x11-wm/libepplet/files/patch-Makefile.in
deleted file mode 100644
index 7b3384b60be..00000000000
--- a/x11-wm/libepplet/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu Nov 6 07:09:39 2003
-+++ Makefile.in Mon Dec 8 02:20:28 2003
-@@ -107,7 +107,7 @@
-
- AUTOMAKE_OPTIONS = foreign
-
--SUBDIRS = api epplets debian
-+SUBDIRS = api debian
-
- EXTRA_DIST = autogen.sh epplets.spec
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/x11-wm/libepplet/files/patch-configure b/x11-wm/libepplet/files/patch-configure
deleted file mode 100644
index 8ed049a5217..00000000000
--- a/x11-wm/libepplet/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Aug 26 12:12:44 2003
-+++ configure Mon Dec 8 02:20:46 2003
-@@ -5414,6 +5414,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'