aboutsummaryrefslogtreecommitdiffstats
path: root/x11/e17-module-eveil
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-11 03:57:00 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-11 03:57:00 +0800
commitb4ad2b1a83a697b0dc6757c2d1b04c08e142fc1c (patch)
tree406cbc51410ce465638372e15ac136b62b1705fe /x11/e17-module-eveil
parentf49aaea1eedb5d775bba183f6d747ffc8ec6a4dd (diff)
downloadfreebsd-ports-graphics-b4ad2b1a83a697b0dc6757c2d1b04c08e142fc1c.tar.gz
freebsd-ports-graphics-b4ad2b1a83a697b0dc6757c2d1b04c08e142fc1c.tar.zst
freebsd-ports-graphics-b4ad2b1a83a697b0dc6757c2d1b04c08e142fc1c.zip
This e17 module allows users to set timers and alarms.
Author: Laurent 'kiwi' Ghigonis <ooookiwi@free.fr> WWW: http://www.enlightenment.org PR: ports/100008 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'x11/e17-module-eveil')
-rw-r--r--x11/e17-module-eveil/Makefile36
-rw-r--r--x11/e17-module-eveil/distinfo3
-rw-r--r--x11/e17-module-eveil/files/patch-configure11
-rw-r--r--x11/e17-module-eveil/files/patch-e_mod_main.c18
-rw-r--r--x11/e17-module-eveil/pkg-descr4
-rw-r--r--x11/e17-module-eveil/pkg-plist10
6 files changed, 82 insertions, 0 deletions
diff --git a/x11/e17-module-eveil/Makefile b/x11/e17-module-eveil/Makefile
new file mode 100644
index 00000000000..c068f1f0307
--- /dev/null
+++ b/x11/e17-module-eveil/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-eveil
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eveil
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module to set alarms and timers
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-eveil/distinfo b/x11/e17-module-eveil/distinfo
new file mode 100644
index 00000000000..e32f420f507
--- /dev/null
+++ b/x11/e17-module-eveil/distinfo
@@ -0,0 +1,3 @@
+MD5 (eveil-20060707.tar.bz2) = 96ad35d8454ca13507f54153947a17aa
+SHA256 (eveil-20060707.tar.bz2) = 2c8361145a7d1ef66e6576adbdc84fbbfce03a368ddb2c852f660f0b1a1d48ee
+SIZE (eveil-20060707.tar.bz2) = 432968
diff --git a/x11/e17-module-eveil/files/patch-configure b/x11/e17-module-eveil/files/patch-configure
new file mode 100644
index 00000000000..bc913371e95
--- /dev/null
+++ b/x11/e17-module-eveil/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 16:14:40 2006
++++ configure Fri Jun 23 16:14:53 2006
+@@ -21497,7 +21497,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-eveil/files/patch-e_mod_main.c b/x11/e17-module-eveil/files/patch-e_mod_main.c
new file mode 100644
index 00000000000..8283e4c5d88
--- /dev/null
+++ b/x11/e17-module-eveil/files/patch-e_mod_main.c
@@ -0,0 +1,18 @@
+--- e_mod_main.c.orig Sun Jul 9 16:54:17 2006
++++ e_mod_main.c Sun Jul 9 16:54:39 2006
+@@ -633,7 +633,6 @@
+ static double
+ _epoch_find_date(char *date, int hour, int minute)
+ {
+- extern long timezone;
+ extern int daylight;
+ struct tm ts;
+ time_t t;
+@@ -663,7 +662,6 @@
+ static double
+ _epoch_find_next(int day_monday, int day_tuesday, int day_wenesday, int day_thursday, int day_friday, int day_saturday, int day_sunday, int hour, int minute)
+ {
+- extern long timezone;
+ extern int daylight;
+ int day_week[7];
+ struct tm ts;
diff --git a/x11/e17-module-eveil/pkg-descr b/x11/e17-module-eveil/pkg-descr
new file mode 100644
index 00000000000..c23c0248121
--- /dev/null
+++ b/x11/e17-module-eveil/pkg-descr
@@ -0,0 +1,4 @@
+This e17 module allows users to set timers and alarms.
+
+Author: Laurent 'kiwi' Ghigonis <ooookiwi@free.fr>
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-eveil/pkg-plist b/x11/e17-module-eveil/pkg-plist
new file mode 100644
index 00000000000..d65c3c9b28e
--- /dev/null
+++ b/x11/e17-module-eveil/pkg-plist
@@ -0,0 +1,10 @@
+lib/enlightenment/modules/eveil/eveil.edc
+lib/enlightenment/modules/eveil/eveil.edj
+lib/enlightenment/modules/eveil/module.a
+lib/enlightenment/modules/eveil/module.eap
+lib/enlightenment/modules/eveil/module.la
+lib/enlightenment/modules/eveil/module.so
+lib/enlightenment/modules/eveil/vera.ttf
+%%NLS%%share/locale/it/LC_MESSAGES/eveil.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/eveil.mo
+@dirrm lib/enlightenment/modules/eveil