aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-terminal
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /x11/gnome-terminal
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-graphics-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-graphics-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-graphics-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'x11/gnome-terminal')
-rw-r--r--x11/gnome-terminal/Makefile8
-rw-r--r--x11/gnome-terminal/distinfo6
-rw-r--r--x11/gnome-terminal/files/patch-src_terminal-screen.c2
-rw-r--r--x11/gnome-terminal/pkg-plist4
4 files changed, 12 insertions, 8 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index 936f8ad397d..9736b570884 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-terminal/Makefile,v 1.125 2009/10/19 20:14:29 kwm Exp $
+# $MCom: ports/x11/gnome-terminal/Makefile,v 1.132 2010/04/28 02:58:55 mezz Exp $
#
PORTNAME= gnome-terminal
-PORTVERSION= 2.28.2
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -23,7 +22,8 @@ USE_BZIP2= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
USE_XORG= sm
-USE_GNOME= gnomeprefix gnomehack intlhack gconf2 vte gnomedocutils
+USE_GNOME= gnomeprefix gnomehack intlhack gconf2 vte gnomedocutils \
+ libgnome
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11/gnome-terminal/distinfo b/x11/gnome-terminal/distinfo
index 78716296d92..5f3e251d1b1 100644
--- a/x11/gnome-terminal/distinfo
+++ b/x11/gnome-terminal/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-terminal-2.28.2.tar.bz2) = aa053ff38932cf032c70ab6522603053
-SHA256 (gnome2/gnome-terminal-2.28.2.tar.bz2) = ccf2547c579755ec9b6f727add6bb327bbda95ac621aa6e0738fbd37ab6c9c78
-SIZE (gnome2/gnome-terminal-2.28.2.tar.bz2) = 2194820
+MD5 (gnome2/gnome-terminal-2.30.1.tar.bz2) = fed3235a053ce34a16218bfe1c2202ca
+SHA256 (gnome2/gnome-terminal-2.30.1.tar.bz2) = 6f30ff97c0798dbfdc8e0910427d88d1d210b8b63f3d0a238a3d48ef2a280cd7
+SIZE (gnome2/gnome-terminal-2.30.1.tar.bz2) = 2250757
diff --git a/x11/gnome-terminal/files/patch-src_terminal-screen.c b/x11/gnome-terminal/files/patch-src_terminal-screen.c
index 52f80dd55eb..3af16e2e363 100644
--- a/x11/gnome-terminal/files/patch-src_terminal-screen.c
+++ b/x11/gnome-terminal/files/patch-src_terminal-screen.c
@@ -50,7 +50,7 @@
}
}
+#else
-+ int fgpid;
++ int fgpid = pid;
+#if __FreeBSD_version > 800018 || (__FreeBSD_version < 800000 && __FreeBSD_version >= 700104)
+#ifndef HAVE_KINFO_GETFILE
+ name[0] = CTL_KERN;
diff --git a/x11/gnome-terminal/pkg-plist b/x11/gnome-terminal/pkg-plist
index 1647061baee..04dd19834a1 100644
--- a/x11/gnome-terminal/pkg-plist
+++ b/x11/gnome-terminal/pkg-plist
@@ -86,6 +86,7 @@ share/locale/be@latin/LC_MESSAGES/gnome-terminal.mo
share/locale/bg/LC_MESSAGES/gnome-terminal.mo
share/locale/bn/LC_MESSAGES/gnome-terminal.mo
share/locale/bn_IN/LC_MESSAGES/gnome-terminal.mo
+share/locale/br/LC_MESSAGES/gnome-terminal.mo
share/locale/bs/LC_MESSAGES/gnome-terminal.mo
share/locale/ca/LC_MESSAGES/gnome-terminal.mo
share/locale/ca@valencia/LC_MESSAGES/gnome-terminal.mo
@@ -99,6 +100,7 @@ share/locale/en_CA/LC_MESSAGES/gnome-terminal.mo
share/locale/en_GB/LC_MESSAGES/gnome-terminal.mo
share/locale/es/LC_MESSAGES/gnome-terminal.mo
share/locale/et/LC_MESSAGES/gnome-terminal.mo
+share/locale/en@shaw/LC_MESSAGES/gnome-terminal.mo
share/locale/eu/LC_MESSAGES/gnome-terminal.mo
share/locale/fa/LC_MESSAGES/gnome-terminal.mo
share/locale/fi/LC_MESSAGES/gnome-terminal.mo
@@ -258,6 +260,8 @@ share/omf/gnome-terminal/gnome-terminal-zh_TW.omf
@dirrmtry share/locale/hy
@dirrmtry share/locale/fur/LC_MESSAGES
@dirrmtry share/locale/fur
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/ca@valencia/LC_MESSAGES