aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnomecore
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /x11/gnomecore
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-graphics-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-graphics-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-graphics-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'x11/gnomecore')
-rw-r--r--x11/gnomecore/Makefile18
-rw-r--r--x11/gnomecore/files/patch-ah83
-rw-r--r--x11/gnomecore/files/patch-idl::Makefile.in13
-rw-r--r--x11/gnomecore/pkg-plist38
4 files changed, 51 insertions, 101 deletions
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index f34ea21be9b..8ce415d64a7 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -15,18 +15,15 @@ DIST_SUBDIR= gnome
MAINTAINER?= gnome@FreeBSD.org
-LIB_DEPENDS= gtkhtml.21:${PORTSDIR}/www/gtkhtml
-RUN_DEPENDS= ${X11BASE}/share/gnome/sounds/login.wav:${PORTSDIR}/audio/gnomeaudio
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier libcapplet libglade gnomeaudio \
+ libpanel
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
- --with-gtkhtml=${X11BASE} \
- --disable-gtk-doc
+CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -40,11 +37,8 @@ MAN1= deskguide_applet.1 gmenu.1 gnome-about.1 gnome-convert.1 \
session-properties-capplet.1
MAN5= default.session.5
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/x11/gnomecore/files/patch-ah b/x11/gnomecore/files/patch-ah
index b64f4f45357..9c12f14097d 100644
--- a/x11/gnomecore/files/patch-ah
+++ b/x11/gnomecore/files/patch-ah
@@ -1,70 +1,51 @@
---- panel/Makefile.in.orig Tue May 23 04:25:47 2000
-+++ panel/Makefile.in Fri May 26 15:30:48 2000
-@@ -169,7 +169,7 @@
- libpanel_appletinclude_HEADERS = applet-widget.h gnome-panel.h
+
+$FreeBSD$
+
+--- panel/Makefile.in.orig Sun Jul 7 11:41:07 2002
++++ panel/Makefile.in Wed Jul 10 18:02:24 2002
+@@ -217,7 +217,7 @@
+ libpanel_appletincludedir = $(includedir)
+ libpanel_statusincludedir = $(includedir)
+
+-lib_LTLIBRARIES = libpanel_applet.la libpanel_status.la
++lib_LTLIBRARIES = libpanel_status.la
+
+ CORBA_SRCLIST = \
+ gnome-panel-stubs.c \
+@@ -239,7 +239,7 @@
+ gnome-panel.h
-libpanel_applet_la_LDFLAGS = -version-info 0:1:0 -rpath $(libdir)
+libpanel_applet_la_LDFLAGS = -version-info 5:0:0 -rpath $(libdir)
libpanel_applet_la_LIBADD = $(ORB_LIBS) -lm $(DL_LIB)
- libpanel_status_la_SOURCES = status-docklet.c $(CORBA_SRCLIST)
-@@ -178,7 +178,7 @@
- libpanel_statusinclude_HEADERS = status-docklet.h
+ libpanel_status_la_SOURCES = \
+@@ -251,7 +251,7 @@
+ status-docklet.h
-libpanel_status_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
+libpanel_status_la_LDFLAGS = -version-info 5:0:0 -rpath $(libdir)
libpanel_status_la_LIBADD = $(ORB_LIBS) -lm $(DL_LIB)
- BUILT_SOURCES = $(CORBA_SRCLIST)
-@@ -210,7 +210,7 @@
- EXTRA_DIST = panelrc.in panel.in appletsConf.sh.in dockletsConf.sh.in panel.gnorba panel.soundlist APPLET_WRITING panel.hints gnome-panel-properties.desktop nothing.cP title-item.gob
+ bad_applet_SOURCES = bad-applet.c
+@@ -435,8 +435,8 @@
+ $(man_MANS)
-confexecdir = $(libdir)
+-confexec_DATA = appletsConf.sh dockletsConf.sh
+confexecdir = $(sysconfdir)
- confexec_DATA = appletsConf.sh dockletsConf.sh
++confexec_DATA = dockletsConf.sh
panelgnorbadir = $(sysconfdir)/CORBA/servers
---- panel/foobar-widget.c.orig Wed Sep 20 00:03:43 2000
-+++ panel/foobar-widget.c Mon Sep 25 14:26:18 2000
-@@ -602,7 +602,7 @@
- FALSE, "apps");
- foo->settings =
- append_folder_menu(menu_bar, _("Settings"), NULL, TRUE,
-- "gnome/apps/Settings");
-+ "apps/Settings");
- append_desktop_menu (menu_bar);
-
- gtk_box_pack_start (GTK_BOX (foo->hbox), menu_bar, FALSE, FALSE, 0);
---- panel/menu.c.orig Fri Apr 27 15:46:00 2001
-+++ panel/menu.c Fri May 4 15:11:16 2001
-@@ -147,3 +147,3 @@
- and a level down*/
-- menu = gnome_datadir_file ("gnome/apps");
-+ menu = gnome_datadir_file ("apps");
- if (menu != NULL)
-@@ -3436,3 +3436,3 @@
- {
-- char *menudir = gnome_datadir_file ("gnome/apps");
-+ char *menudir = gnome_datadir_file ("apps");
-
-@@ -4543,4 +4543,4 @@
- GTK_SIGNAL_FUNC(add_menu_to_panel),
-- "gnome/apps");
-- setup_internal_applet_drag(submenuitem, "MENU:gnome/apps");
-+ "apps");
-+ setup_internal_applet_drag(submenuitem, "MENU:apps");
-
---- panel/menu-properties.c.orig Sat Sep 9 19:52:26 2000
-+++ panel/menu-properties.c Mon Sep 25 14:28:44 2000
-@@ -40,7 +40,7 @@
- arguments = ".";
+ panelgnorba_DATA = panel.gnorba
+@@ -1278,7 +1278,6 @@
+ install-data-am: install-man install-deskDATA install-gladeDATA \
+ install-hintsDATA install-panelgnorbaDATA \
+ install-soundlistDATA install-sysDATA \
+- install-libpanel_appletincludeHEADERS \
+ install-libpanel_statusincludeHEADERS
+ install-data: install-data-recursive
- if(strcmp(arguments, ".") == 0)
-- this_menu = gnome_unconditional_datadir_file ("gnome/apps");
-+ this_menu = gnome_unconditional_datadir_file ("apps");
- else if (*arguments == '/')
- this_menu = g_strdup (arguments);
- else if (*arguments == '~')
diff --git a/x11/gnomecore/files/patch-idl::Makefile.in b/x11/gnomecore/files/patch-idl::Makefile.in
new file mode 100644
index 00000000000..712f85a01e9
--- /dev/null
+++ b/x11/gnomecore/files/patch-idl::Makefile.in
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2002/07/10 14:57:23 1.1
++++ idl/Makefile.in 2002/07/10 14:58:38
+@@ -180,7 +180,6 @@
+ idldir = $(datadir)/idl
+
+ idl_DATA = \
+- gnome-panel.idl \
+ help-browser.idl \
+ Terminal.idl
+
diff --git a/x11/gnomecore/pkg-plist b/x11/gnomecore/pkg-plist
index dc0dff962af..fcf3022d02e 100644
--- a/x11/gnomecore/pkg-plist
+++ b/x11/gnomecore/pkg-plist
@@ -31,15 +31,12 @@ etc/CORBA/servers/gnome-terminal.gnorba
etc/CORBA/servers/help-browser.gnorba
etc/CORBA/servers/panel.gnorba
etc/CORBA/servers/tasklist_applet.gnorba
-etc/appletsConf.sh
etc/dockletsConf.sh
etc/gnome/panel-config/panel
etc/gnome/panel-config/panel.d/default/Applet_Config
etc/gnome/panel-config/panel.d/default/panel
etc/sound/events/mailcheck.soundlist
etc/sound/events/panel.soundlist
-include/applet-widget.h
-include/gnome-panel.h
include/status-docklet.h
lib/libfish_applet.a
lib/libfish_applet.so
@@ -47,9 +44,6 @@ lib/libfish_applet.so.5
lib/libgen_util_applet.a
lib/libgen_util_applet.so
lib/libgen_util_applet.so.5
-lib/libpanel_applet.a
-lib/libpanel_applet.so
-lib/libpanel_applet.so.5
lib/libpanel_status.a
lib/libpanel_status.so
lib/libpanel_status.so.5
@@ -866,7 +860,6 @@ share/gnome/help/tasklist_applet/eu/tasklist_applet.sgml
share/gnome/help/tasklist_applet/eu/topic.dat
share/gnome/hints/panel.hints
share/gnome/idl/Terminal.idl
-share/gnome/idl/gnome-panel.idl
share/gnome/idl/help-browser.idl
share/gnome/mc/templates/Emacs.desktop
share/gnome/mc/templates/Eterm.desktop
@@ -1136,13 +1129,7 @@ share/locale/wa/LC_MESSAGES/gnome-core.mo
share/locale/zh_CN/LC_MESSAGES/gnome-core.mo
share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/pixmaps/tiles
-@dirrm share/gnome/pixmaps/splash
-@dirrm share/gnome/pixmaps/mailcheck
-@dirrm share/gnome/pixmaps/fish
-@dirrm share/gnome/panel
@dirrm share/gnome/omf/gnome-core
-@dirrm share/gnome/mc/templates
-@dirrm share/gnome/mc
@dirrm share/gnome/hints
@dirrm share/gnome/help/tasklist_applet/eu/stylesheet-images
@dirrm share/gnome/help/tasklist_applet/eu/figures
@@ -1223,8 +1210,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/help/mailcheck_applet
@dirrm share/gnome/help/lgpl/C/stylesheet-images
@dirrm share/gnome/help/lgpl/C/figures
-@dirrm share/gnome/help/lgpl/C
-@dirrm share/gnome/help/lgpl
@dirrm share/gnome/help/help-browser/wa
@dirrm share/gnome/help/help-browser/uk
@dirrm share/gnome/help/help-browser/no
@@ -1245,8 +1230,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/help/help-browser
@dirrm share/gnome/help/gpl/C/stylesheet-images
@dirrm share/gnome/help/gpl/C/figures
-@dirrm share/gnome/help/gpl/C
-@dirrm share/gnome/help/gpl
@dirrm share/gnome/help/gnome-terminal/no/stylesheet-images
@dirrm share/gnome/help/gnome-terminal/no/figures
@dirrm share/gnome/help/gnome-terminal/no
@@ -1267,8 +1250,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/help/gnome-terminal/da
@dirrm share/gnome/help/gnome-terminal/C/stylesheet-images
@dirrm share/gnome/help/gnome-terminal/C/figures
-@dirrm share/gnome/help/gnome-terminal/C
-@dirrm share/gnome/help/gnome-terminal
@dirrm share/gnome/help/gnome-feedback/no/stylesheet-images
@dirrm share/gnome/help/gnome-feedback/no/figures
@dirrm share/gnome/help/gnome-feedback/no
@@ -1298,8 +1279,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/help/fish_applet
@dirrm share/gnome/help/fdl/C/stylesheet-images
@dirrm share/gnome/help/fdl/C/figures
-@dirrm share/gnome/help/fdl/C
-@dirrm share/gnome/help/fdl
@dirrm share/gnome/help/desk-guide_applet/it/stylesheet-images
@dirrm share/gnome/help/desk-guide_applet/it/figures
@dirrm share/gnome/help/desk-guide_applet/it
@@ -1332,23 +1311,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-core.mo
@dirrm share/gnome/help/clock_applet/C/figures
@dirrm share/gnome/help/clock_applet/C
@dirrm share/gnome/help/clock_applet
-@dirrm share/gnome/gnome-terminal/glade
-@dirrm share/gnome/gnome-terminal
-@dirrm share/gnome/gnome-about
-@dirrm share/gnome/apps/Utilities
-@dirrm share/gnome/apps/System
-@dirrm share/gnome/apps/Multimedia
-@dirrm share/gnome/apps/Internet
-@dirrm share/gnome/apps/Graphics
-@dirrm share/gnome/apps/Games
-@dirrm share/gnome/apps/Development
-@dirrm share/gnome/applets/Utility
-@dirrm share/gnome/applets/Network
-@dirrm share/gnome/applets/Multimedia
-@dirrm share/gnome/applets/Monitors
-@dirrm share/gnome/applets/Clocks
-@dirrm share/gnome/applets/Amusements
-@dirrm share/gnome/applets
@dirrm share/doc/panel/panel
@dirrm share/doc/panel
@dirrm etc/gnome/panel-config/panel.d/default