aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase3/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-02-10 11:32:52 +0800
committerlofi <lofi@FreeBSD.org>2007-02-10 11:32:52 +0800
commit84686ce1c67eb73ac399c19557b014d705717df7 (patch)
tree859a719ba1d9a0f8ac4270127d4bf77a6f47db0b /x11/kdebase3/Makefile
parenta1326e0bdea7ca9f840656ef853f1f215751b899 (diff)
downloadfreebsd-ports-graphics-84686ce1c67eb73ac399c19557b014d705717df7.tar.gz
freebsd-ports-graphics-84686ce1c67eb73ac399c19557b014d705717df7.tar.zst
freebsd-ports-graphics-84686ce1c67eb73ac399c19557b014d705717df7.zip
Fix various problems in the media kioslave:
- Correct ejecting of mounted volumes (unmount before eject). - Mounting of removable media drives (such as CD-ROM drives) listed in /etc/fstab (removes checking linux's "user" mount option). - Polling floppy drives over the mount state (FreeBSD HAL doesn't do this). - Informing the fileview when HAL notifies that mounting is completed. - Mounting cdrom volume in locale charset. Note: Requires cd9660_iconv! PR: ports/108949 Submitted by: Maxim Samsonov <xors@sendmail.ru> - Disable polling of nfs shares in the fstabbackend. Mounting/Unmounting is broken and the polling can cause DBus aborts that take kded with them.
Diffstat (limited to 'x11/kdebase3/Makefile')
-rw-r--r--x11/kdebase3/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 870bc4b6b30..993cd069c13 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -71,7 +71,8 @@ RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
.endif
.if defined(WITH_HAL) && ${OSVERSION} > 500035
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.cpp
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.cpp \
+ ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.h
LIB_DEPENDS+= dbus-qt-1.1:${PORTSDIR}/devel/dbus-qt3 \
hal.1:${PORTSDIR}/sysutils/hal
PLIST_SUB+= MEDIA=""