aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase3
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-03-03 12:18:22 +0800
committerpetef <petef@FreeBSD.org>2002-03-03 12:18:22 +0800
commitdcf87c9f4c79667def748fe0ef48e9ef577c721f (patch)
tree8cc17d23e1154db54b3ce13f515e2b7f8a0ea886 /x11/kdebase3
parentd052a175e5b3f384b2f3f82f54d0a0b8d2781ac7 (diff)
downloadfreebsd-ports-graphics-dcf87c9f4c79667def748fe0ef48e9ef577c721f.tar.gz
freebsd-ports-graphics-dcf87c9f4c79667def748fe0ef48e9ef577c721f.tar.zst
freebsd-ports-graphics-dcf87c9f4c79667def748fe0ef48e9ef577c721f.zip
Make the "default" target failback on KDE if the user doesn't have a
.xsession file. Before this fix, kdm wouldn't log the user in with "default" if no .xsession existed.. but it seems to make sense that KDE's display manager should fall back to KDE by default. Bump PORTREVISION. PR: 35223 Submitted by: Alan E <alane@geeksrus.net>
Diffstat (limited to 'x11/kdebase3')
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase3/files/patch-kdm::kfrontend::genkdmconf.c14
2 files changed, 13 insertions, 3 deletions
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index f5be27d7750..8c4aa2a9dfb 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdebase
PORTVERSION= 2.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdebase3/files/patch-kdm::kfrontend::genkdmconf.c b/x11/kdebase3/files/patch-kdm::kfrontend::genkdmconf.c
index d520f23414b..2c852c344aa 100644
--- a/x11/kdebase3/files/patch-kdm::kfrontend::genkdmconf.c
+++ b/x11/kdebase3/files/patch-kdm::kfrontend::genkdmconf.c
@@ -1,5 +1,5 @@
--- kdm/kfrontend/genkdmconf.c.orig Mon Nov 5 21:40:03 2001
-+++ kdm/kfrontend/genkdmconf.c Sat Jan 5 23:49:40 2002
++++ kdm/kfrontend/genkdmconf.c Fri Feb 22 19:34:28 2002
@@ -212,7 +212,7 @@
*/
@@ -31,7 +31,17 @@
"-x " KDMCONF "/Xservers "
#endif
"$USER\n"
-@@ -1781,7 +1781,7 @@
+@@ -1658,7 +1658,8 @@
+ " exec xterm -geometry 80x24-0-0 $*\n"
+ " ;;\n"
+ " \"\"|default)\n"
+-" exec $HOME/.xsession $*\n"
++" test -x $HOME/.xsession && exec $HOME/.xsession $*\n"
++" sess=kde\n"
+ " ;;\n"
+ "esac\n"
+ "\n"
+@@ -1781,7 +1782,7 @@
}
addKdePath ("UserPath", DEF_USER_PATH);
addKdePath ("SystemPath", DEF_SYSTEM_PATH);