aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs3
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-25 06:15:59 +0800
committerwill <will@FreeBSD.org>2001-03-25 06:15:59 +0800
commit63e44ba845351114773cc3c18846cac95bc4be15 (patch)
tree87c0cdd041f295f742326ff15825dbec8b7ace9b /x11/kdelibs3
parent8e2927fc3c616d1f4d0dbbeb505045d2273dfcfb (diff)
downloadfreebsd-ports-graphics-63e44ba845351114773cc3c18846cac95bc4be15.tar.gz
freebsd-ports-graphics-63e44ba845351114773cc3c18846cac95bc4be15.tar.zst
freebsd-ports-graphics-63e44ba845351114773cc3c18846cac95bc4be15.zip
Bring in my fixes for KDE2 for users of XFree86 4.0.x. Basically, what
this involves is this: Cull GL from Qt by default, but still provide a Qt+GL library that may or may not have threads. Then also provide a Qt library that has threads but not GL. This allows us to make KDE2 depend on a library that will *not* have threads, ever. Threads will be revisited at a later date. Ports that require GL support need to be updated to use the hacked library, libqtgl.so.4. The net result is that we bloat our qt2 package by 1.5-2.5MB for compatability. Also, static qt will not have GL support. Introduce bsd.kde.mk, which will be tested on bento before becoming fully activated. Replace qt22-static with qt2-static, since it's just a proxy. Update qt-designer to depend on qt23. Also make the old hack to package the correct lib obsolete by using PLIST_SUB instead. Miscellaneous changes: remove LIBQTFILE from CONFIGURE_ENV, it's not used anymore. Solve namespace pollution problems with the devel/pth and devel/libgnugetopt ports. Hopefully. Suggested by: ade, asami, sobomax (bsd.kde.mk) Repocopied by: asami (qt22-static --> qt2-static)
Diffstat (limited to 'x11/kdelibs3')
-rw-r--r--x11/kdelibs3/Makefile44
1 files changed, 8 insertions, 36 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 08b63213a6b..170ff7b40d4 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -27,40 +27,18 @@ USE_NEWGCC= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-# Hack to make pthread support work correctly.
-.if exists(${X11BASE}/lib/libqt2-mt.so)
-.if exists(${X11BASE}/lib/libXThrStub.so)
-QTNAME= qt2-mt
-.if ${OSVERSION} >= 500016
-PTHREAD_CFLAGS=
-PTHREAD_LIBS= -lc_r
-.else
-PTHREAD_CFLAGS= -D_THREAD_SAFE
-PTHREAD_LIBS= -pthread
-.endif
-.else
-QTNAME= qt2
-PTHREAD_CFLAGS=
-PTHREAD_LIBS=
-.endif
-.endif
-
-CFLAGS+= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include -D_GETOPT_H ${PTHREAD_CFLAGS}" \
- MOC="${MOC}" LIBQT="-l${QTNAME}" LIBQTFILE="lib${QTNAME}" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++ ${PTHREAD_LIBS}" \
- LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++ ${PTHREAD_LIBS}"
+CONFIGURE_ENV= MOC="${MOC}" LIBQT="-lqt2" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include -D_GETOPT_H" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"
PLIST_SUB+= LIBVER="${SOMAJOR}"
+.include <bsd.port.pre.mk>
+
pre-fetch:
.if ${OSVERSION} <= 410002
@${ECHO}
@@ -74,15 +52,9 @@ pre-fetch:
.endif
pre-configure:
-.for NUM in 1 3
- (find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
- "s@version-info ${NUM}:0@version-info ${SOMAJOR}:${SOMINOR}@g")
-.endfor
-
-post-configure:
- @${CP} ${WRKSRC}/libtool ${WRKSRC}/libtool.orig
- ${SED} -e 's@\\\$$compiler_flags@\\\$$compiler_flags ${PTHREAD_LIBS}@g' ${WRKSRC}/libtool.orig \
- > ${WRKSRC}/libtool
+ (find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi.orig -e \
+ "s@version-info 1:0@version-info ${SOMAJOR}:${SOMINOR}@g; \
+ s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g")
post-install:
.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula kio kjs \