aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs4/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-05-29 09:01:22 +0800
committerwill <will@FreeBSD.org>2000-05-29 09:01:22 +0800
commita059d99cde06e335b1077be607968fc72e1590d1 (patch)
treed973e638d3b317d75d3f5a7985b623b49d994a90 /x11/kdelibs4/Makefile
parenta1ff4eba87768957714f69151e85bf0568c84f78 (diff)
downloadfreebsd-ports-graphics-a059d99cde06e335b1077be607968fc72e1590d1.tar.gz
freebsd-ports-graphics-a059d99cde06e335b1077be607968fc72e1590d1.tar.zst
freebsd-ports-graphics-a059d99cde06e335b1077be607968fc72e1590d1.zip
This should fix all the compile problems bento (and others probably) has
with missing .so's. I'm not sure how I left this out in the original import since this stuff was in kdelibs11. :-( Found by: bento
Diffstat (limited to 'x11/kdelibs4/Makefile')
-rw-r--r--x11/kdelibs4/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index e92dfed8789..af08a6ae490 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -34,4 +34,14 @@ USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}" \
PLIST_SUB+= LIBVER="${SOMAJOR}"
+.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula khtml kio kjs kmid \
+ kparts kspell ksycoca kwrite
+ @${LN} -sf ${PREFIX}/lib/lib${LIB}.so.${SOMAJOR} ${PREFIX}/lib/lib${LIB}.so
+.endfor
+.for LIB in artsc artscbackend artsdsp artsflow artsflow_idl kmedia2_idl qtmcop \
+ soundserver_idl x11globalcomm
+ @${LN} -sf ${PREFIX}/lib/lib${LIB}.so.0 ${PREFIX}/lib/lib${LIB}.so
+.endfor
+ @${LN} -sf ${PREFIX}/lib/libkjava.so.1 ${PREFIX}/lib/libkjava.so
+
.include <bsd.port.mk>